aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
Diffstat (limited to 'cad')
-rw-r--r--cad/openscad/Makefile27
-rw-r--r--cad/openscad/distinfo4
-rw-r--r--cad/openscad/pkg-plist9
3 files changed, 24 insertions, 16 deletions
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
index 8d816a896fde..a5b60433c208 100644
--- a/cad/openscad/Makefile
+++ b/cad/openscad/Makefile
@@ -1,29 +1,26 @@
-# New ports collection makefile for: openscad
-# Date created: 17 August 2011
# Whom: Michael Reifenberger <mr@freebsd.org>
-#
# $FreeBSD$
-#
PORTNAME= openscad
-PORTVERSION= 2011.12
-PORTREVISION= 1
+PORTVERSION= 2013.01
CATEGORIES= cad
-MASTER_SITES= https://cloud.github.com/downloads/openscad/openscad/
+MASTER_SITES= GOOGLE_CODE
DISTNAME= openscad-${PORTVERSION}.src
MAINTAINER= mr@FreeBSD.org
COMMENT= The programmer's solid 3D CAD modeller
+LICENSE= GPLv2
+
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
- flex:${PORTSDIR}/textproc/flex \
+ ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2 \
${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boost-libs
#RUN_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boost-libs
-LIB_DEPENDS= GLU.1:${PORTSDIR}/graphics/libGLU \
- gmp.10:${PORTSDIR}/math/gmp \
- mpfr.4:${PORTSDIR}/math/mpfr \
- CGAL.5:${PORTSDIR}/math/cgal \
+LIB_DEPENDS= GLU:${PORTSDIR}/graphics/libGLU \
+ gmp:${PORTSDIR}/math/gmp \
+ mpfr:${PORTSDIR}/math/mpfr \
+ CGAL:${PORTSDIR}/math/cgal \
opencsg:${PORTSDIR}/graphics/opencsg
USE_GL= glew
@@ -35,11 +32,15 @@ QMAKE_FLAGS = VERSION=${PORTVERSION}
MAKE_ENV = INSTALL_ROOT=${DESTDIR}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-pre-configure:
+post-patch:
${REINPLACE_CMD} -e 's,XXXFLEXXX,"${LOCALBASE}/bin/flex",' \
${WRKSRC}/openscad.pro
${REINPLACE_CMD} -e 's,XXXBISONXXX,"${LOCALBASE}/bin/bison",' \
${WRKSRC}/openscad.pro
+ ${REINPLACE_CMD} -e 's,$$$$PREFIX,${PREFIX},' \
+ ${WRKSRC}/openscad.pro
+ ${REINPLACE_CMD} -e 's#/usr/local/bin/flex#${LOCALBASE}/bin/flex#g' \
+ ${WRKSRC}/flex.pri
do-configure:
cd ${WRKSRC} && \
diff --git a/cad/openscad/distinfo b/cad/openscad/distinfo
index d0c37e8032b7..e5f268cf9e14 100644
--- a/cad/openscad/distinfo
+++ b/cad/openscad/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openscad-2011.12.src.tar.gz) = 507e12bb2a4bb556ee8fcdce9779860d89071e924678b2200d82fdb5fae7583d
-SIZE (openscad-2011.12.src.tar.gz) = 3247723
+SHA256 (openscad-2013.01.src.tar.gz) = 2ef078b588c42f7ba873850f40a4695c6a47f3805d1560717dd3f98fe8082007
+SIZE (openscad-2013.01.src.tar.gz) = 3459766
diff --git a/cad/openscad/pkg-plist b/cad/openscad/pkg-plist
index 16d65334eb02..3498d72524ed 100644
--- a/cad/openscad/pkg-plist
+++ b/cad/openscad/pkg-plist
@@ -1,4 +1,6 @@
bin/openscad
+share/applications/openscad.desktop
+share/pixmaps/openscad.png
%%DATADIR%%/examples/example001.scad
%%DATADIR%%/examples/example002.scad
%%DATADIR%%/examples/example003.scad
@@ -28,13 +30,17 @@ bin/openscad
%%DATADIR%%/examples/example020.scad
%%DATADIR%%/examples/example021.scad
%%DATADIR%%/examples/example022.scad
+%%DATADIR%%/examples/example023.scad
%%DATADIR%%/libraries/MCAD/openscad_testing.py
%%DATADIR%%/libraries/MCAD/bearing.scad
%%DATADIR%%/libraries/MCAD/boxes.scad
+%%DATADIR%%/libraries/MCAD/fonts.scad
%%DATADIR%%/libraries/MCAD/hardware.scad
+%%DATADIR%%/libraries/MCAD/lego_compatibility.scad
+%%DATADIR%%/libraries/MCAD/math.scad
+%%DATADIR%%/libraries/MCAD/multiply.scad
%%DATADIR%%/libraries/MCAD/servos.scad
%%DATADIR%%/libraries/MCAD/teardrop.scad
-%%DATADIR%%/libraries/MCAD/math.scad
%%DATADIR%%/libraries/MCAD/transformations.scad
%%DATADIR%%/libraries/MCAD/gridbeam.scad
%%DATADIR%%/libraries/MCAD/curves.scad
@@ -75,3 +81,4 @@ bin/openscad
@dirrm %%DATADIR%%/libraries
@dirrm %%DATADIR%%/examples
@dirrm %%DATADIR%%
+@dirrmtry share/applications
ntw44/cgit/cgit.cgi/freebsd-ports-gnome/commit/UIDs?h=gstreamer&id=df900b437ec7c2b2577139bc843c6ff19efd73a8'>Reserve username and groupname for devel/zookeeper{-devel}skreuzer2012-10-231-0/+1 * [devel/gearmand]:glarkin2012-10-051-0/+1 * Add net-mgmt/ipv6mon, a tool for monitoring IPv6 address usage on a localhrs2012-10-031-0/+1 * - Create gid and uid for tryton daemon and use them via USERS and GROUPS vari...wen2012-09-181-0/+1 * Update c-icap to 0.2.1mm2012-08-151-0/+1 * - use reserverd UID/GIDohauer2012-07-211-0/+1 * - Update to 1.3.9scheidell2012-07-081-0/+1 * add reserved UID/GID for polw (mail/postfix-policyd-weight)ohauer2012-06-071-0/+1 * Add UID and GID for net-mgmt/netmondcrees2012-05-311-0/+1 * preliminary version of update to 0.9.x; GUI, rc-scripts, tests,bf2012-05-291-0/+1 * - Add razorback USERS/GROUPS for upcoming security/razorback* port additionszi2012-05-211-0/+1 * Switch from old way to new way by using USERS.mezz2012-05-211-0/+1 * - Add USER/GROUP, missed from previous commitashish2012-05-161-0/+1 * Add Pandora FMS 4.0.1 - a Flexible Monitoring System.motoyuki2012-04-211-0/+1 * - Change /sbin/nologin to /usr/sbin/nologinsunpoet2012-04-181-1/+1 * Fix condor home directorycrees2012-04-181-1/+1 * Register username and groupname for condorcrees2012-04-131-0/+1 * - Add hadoop 1.0.0clement2012-03-271-0/+1 * Update SQLgrey to 1.8.0mm2012-02-141-0/+1 * Change type of pointers from int to uintptr_t for support 64 bit platforms.osa2012-02-021-0/+1 * Fix path for nologin(8).osa2012-02-021-3/+3 * - Functionality upgrade. Add in *.txt.sample files so that uninstall/pkg_del...scheidell2012-01-121-0/+1 * - Upgrade to 3.2.3.kuriyama2011-11-191-1/+1 * Reserve uid/gid 442 for Quassel IRCmakc2011-10-311-0/+1 * Spell /nonexistEnt correctly for freeswitch user, thus notcrees2011-10-291-1/+1 * Adding _neubot for Neubot's daemon.thierry2011-10-221-0/+1 * The KDE/FreeBSD team is pleased to announce KDE Software Compilationavilla2011-10-171-0/+1 * - Added user and group to prepare for new port devel/trac-bittenglarkin2011-10-141-0/+1 * Add the radns users/groupsbapt2011-09-281-0/+1 * Clarify UPDATING entry for maiad and update vscan user to new home dir.crees2011-09-051-1/+1 * - Add for openerp-serverbeech2011-09-021-0/+1 * Copy line from master.passwd for operator, not passwd.crees2011-08-241-1/+1 * Allow operator user to be used by a port.crees2011-08-241-0/+1 * - Add missing colon delimitersunpoet2011-08-221-16/+16 * - Change /sbin/nologin to /usr/sbin/nologinsunpoet2011-08-221-16/+16 * - Sync jenkins's home as ${JENKINS_HOME} in devel/jenkinslwhsu2011-08-201-1/+1 * Correct name in GECOS field and update shell to nologin.zi2011-08-171-1/+1 * mail/mixminion now uses USERScrees2011-08-151-0/+1 * net/gini now uses USERScrees2011-08-121-0/+1 * - Change zenoss user to have a valid shell, and add an UPDATING entry forpav2011-08-081-1/+1 * net/gatekeeper now uses USERS/GROUPScrees2011-07-261-0/+1 * Add users for net-mgmt/zenosscrees2011-07-221-0/+1 * Add missing entries for tr-ircdcrees2011-07-091-0/+1 * audio/ventrilo-server now uses USERS and GROUPScrees2011-07-081-0/+1 * - Fix a crash when an invalid log file is specified.hrs2011-07-021-0/+1 * Remove duplicate dbxml line.crees2011-06-291-1/+0 * Fix nobody user -- should be master.passwd stylecrees2011-06-151-1/+1 * - Correct GROUP when postfix OPTION is selected [1]crees2011-06-141-0/+1 * . Add entries for dbxml forgotten in databases/dbXML update.glewis2011-06-121-0/+1 * Add an user 'daapd' for audio/mt-daapdrene2011-06-071-0/+1 * Add entries for ports which are converted to the new USERS paradigm.rene2011-06-071-0/+7 * - add a current version of yate (3.3.2p1). This is not a repocopy offlo2011-05-221-0/+1 * - update tor-devel to 0.2.3.1-alphabf2011-05-081-1/+1 * adsuck is a DNS relay that returns NXdomain for hosts that match names in abapt2011-05-071-0/+1 * - Updated to 3.0.0.b30 [1]glarkin2011-05-041-0/+1 * - update to 2.8.3bapt2011-04-241-0/+1 * - Replace pkg-install and pkg-deinstall with USERS and GROUPS in Makefilelwhsu2011-04-231-1/+1 * Update webcamd to 0.1.24.kwm2011-04-211-0/+1 * - Add _tcpproxy for new port net/tcpproxydhn2011-04-031-0/+1 * - rename hobbit to xymondinoex2011-04-021-1/+1 * - Pass -Dbsd_with_getifaddrs to CFLAGS in order to get a correct networkehaupt2011-03-291-0/+1 * Reserve IDs for multimedia/vdr and related ports.nox2011-03-271-0/+1 * Register uid and gid for net/get_iplayerbf2011-03-091-0/+1 * - Register UID and GID for devel/jenkinslwhsu2011-03-071-0/+1 * - Register uid and gid for net/crtmpserversylvio2011-02-281-0/+1 * - Register uid and gid for net-mgmt/icingachinsan2011-02-241-0/+1 * - Register uid and gid for net/erlyvideomiwi2011-02-021-0/+1 * - fix format of my last commit for UID 587ohauer2011-01-061-1/+1 * - register UID/GID 587 for assp user (port mail/assp)ohauer2011-01-061-0/+1 * - Move torrus user to next unoccupied slotpav2010-12-241-1/+1 * - Upgrade to USERS/GROUPSpav2010-12-231-0/+1 * - register UID/GID 542 for _flowd user (port net-mgmt/flowd)ohauer2010-12-211-0/+1 * Add the port of minidlna -- the DLNA-speaking service.mi2010-12-141-0/+1 * Dont declare ${sancp_flags} in command_args.wxs2010-12-131-0/+1 * - add radmind with uid/gid 506 for port sysutils/radmindohauer2010-11-281-0/+1 * . Add a port of the 2.x series of Dovecot:glewis2010-11-271-0/+1 * * Sets up a uhub UID and GID for the daemon to run as.stefan2010-11-111-0/+1 * Add "asterisk" user/group and "dahdi" group.fjoe2010-11-071-0/+1 * Add _tss and _pkcs11 to reserve for security/trousers andnork2010-11-071-0/+2 * Finally upgrade amanda-{server,client} to 3.2.0. Old 2.6.x waskuriyama2010-11-011-0/+1 * - add RC scriptswills2010-10-111-0/+1 * Archiveopteryx is an Internet mail server, optimised to supportashish2010-10-031-0/+1 * BackupPC is a high-performance, enterprise-grade system for backing up Linux,pgollucci2010-09-231-0/+1 * - Convert to USERS/GROUPSpgollucci2010-09-221-0/+1 * tWMS is a tiny WMS server written in Python and using tiles as aamdmi32010-09-081-0/+1 * Use the USERS/GROUPS mechanismlth2010-08-121-0/+1 * - Add user/group shellinabox with uid/gid 139jadawin2010-07-051-0/+1 * Add 'saned' user/group the Right Way.stefan2010-06-281-0/+1 * Fix missing fields in previous commitjpaetzel2010-06-131-1/+1 * - Add activemq for new port net/activemqwen2010-06-121-0/+1 * Add net/freeswitch-core, part of a revamp to the freeswitch portsjpaetzel2010-06-121-0/+1 * - fix Text for meta1dinoex2010-06-041-1/+1 * - Update to 0.7.3pav2010-05-141-0/+1 * Change the home directory of p4admin to /nonexistent because it is not needed.rene2010-05-101-1/+1 * - Added user and group for Drizzle database serverglarkin2010-04-291-0/+1 * - Reserve kumofs uid/gid.kuriyama2010-04-261-0/+1 * - Update to v1.2.6abrix2010-04-241-1/+1 * Minbif aims to use the libpurple library from the Pidgin projectbeat2010-04-151-0/+1 * - Add user and group mfs for MooseFS portwen2010-04-071-0/+1 * - Fix malformed lines, per new portlint(1) checkpav2010-04-061-4/+4 * - reserver GID/UID 924 for upcomming mail/postpalsitetcu2010-03-131-0/+1 * Massive cleanup of the Munin ports:des2010-02-251-0/+1 * - Add user and group for audio/liquidsoapwen2010-02-011-0/+1 * - Update Wolfpack Empire to 4.3.23johans2009-12-281-0/+1 * - Reserve UID/GID 137 for audio/musicpdpav2009-12-071-0/+1 * - Prepare for add new port databases/mongodbwen2009-11-191-0/+1 * - Add 444 for callweaverpav2009-09-181-0/+1 * - Update to 0.8.5beat2009-09-181-0/+1 * - Add UID/GID:211 for devel/py-gitosisnivit2009-09-161-0/+1 * - Fix typo in directory name for undernet user.flz2009-09-111-2/+2 * Add haldaemon with UID/GID 560.flz2009-09-071-0/+1 * Add UID and GID forgotten while adding net-mgmt/noc.bsam2009-08-181-0/+1 * - unbound does not use `unbound' group anymore, but `daemmon' insteadsem2009-08-171-1/+1 * Remove entries for security/trans-proxy-tor and security/dns-proxy-torerwin2009-08-161-2/+0 * Add prosody entries to UIDs & GIDs.vanilla2009-08-051-0/+1 * Register user/group "redis" for the port "databases/redis".skv2009-07-281-0/+1 * - Unify path to nologin as /usr/sbin/nologin. This has been done at leastwxs2009-07-251-8/+8 * - Add fossy user/group for devel/fossology.alepulver2009-07-241-0/+1 * -Add transmission.mezz2009-06-201-1/+2 * - Add GID and UID for emulators/virtualbox.beat2009-06-181-0/+1 * - Add couchdb user and group.wxs2009-06-171-0/+1 * - Register net-mgmt/nefurafan2009-04-071-0/+1 * - Register uid and gid for mail/prayerrafan2009-03-171-0/+1 * Reflect the change of UID/GID of ejabberd.delphij2009-03-161-1/+1 * - Updated to 0.21glarkin2009-03-111-1/+1 * Rework on rc script for www/httptunnel.rafan2009-01-301-0/+1 * Register a fixed UID/GID for the user 'dhcpd' and use that instead of astefan2009-01-121-0/+1 * - Add UID and GID entries for net/rabbitmq.wxs2008-10-291-0/+1 * - Fixed logcheck script silent failure in previous commitglarkin2008-09-111-1/+1 * - Fixed left-over directory problemglarkin2008-09-091-0/+1 * - Update pgbouncer to 1.2.3mm2008-08-121-0/+1 * Reserve numbers for databases/frontbase user.edwin2008-06-131-0/+1 * Switch UIDs to master.passwd compatible format.flz2008-05-201-142/+142 * Style fix, $FreeBSD$ line is a comment, so add a leading '#'.flz2008-05-201-1/+1 * Reserve UID and GID for irc/bitlbee.brix2008-05-201-0/+1 * - Add entries for irc/undernet-ircubeech2008-05-011-0/+1 * - Reserve GID/UID 59 for dns/unboundsem2008-04-291-0/+1 * Reserve 814 for sysutils/puppet*pav2008-04-111-0/+1 * - Add GID and UID for www/openacs and www/openacs-dotlrnmm2008-04-031-0/+2 * - Add GID and UID for net/freeradius2mm2008-04-021-0/+1 * * Don't need p5-Digest-MD5; p5-libwww dependency takes care of that.koitsu2008-03-101-1/+1 * - Register UID for net/phpldapadmin, net/phpldapadmin098rafan2008-03-091-0/+1 * - Add GID and UID for net-im/openfiremiwi2008-03-081-0/+1 * Remove IGNORE; add UID 141 to ports/UIDs, and remove unnecessary Time::HiReskoitsu2008-02-191-0/+1 * - Sort UIDsmiwi2008-02-171-2/+2 * - add hobbit with id 280dinoex2008-01-281-0/+1 * - Reserve UID/GID 240 and 241 for aprsddb2008-01-241-0/+2 * Changes:miwi2008-01-211-0/+1 * Add 913 for _relayd.kuriyama2008-01-211-0/+1 * Inconsistent format of lines in /usr/ports/UIDsedwin2008-01-191-4/+4