aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
Diffstat (limited to 'cad')
-rw-r--r--cad/openvsp/Makefile14
1 files changed, 1 insertions, 13 deletions
diff --git a/cad/openvsp/Makefile b/cad/openvsp/Makefile
index aad42d095c44..b5b773782f2b 100644
--- a/cad/openvsp/Makefile
+++ b/cad/openvsp/Makefile
@@ -37,19 +37,7 @@ WRKSRC= ${WRKDIR}/${GH_PROJECT}-${GH_PROJECT}_${PORTVERSION}
CMAKE_SOURCE_PATH= ${WRKSRC}/SuperProject
CMAKE_INSTALL_PREFIX= ${STAGEDIR}${PREFIX}
-USES= cmake:outsource jpeg
-
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000 && ${OSVERSION} < 1002000
-# Fails to build with GCC 4.9 in 10.1
-USE_GCC= 4.8
-LDFLAGS+= -L${LOCALBASE}/lib/c++
-CXXFLAGS+= -nostdinc++ -isystem ${LOCALBASE}/include/c++/v1
-BUILD_DEPENDS+= ${LOCALBASE}/lib/c++/libstdc++.so:devel/libc++
-.else
-USES += compiler:gcc-c++11-lib
-.endif
+USES= cmake:outsource compiler:gcc-c++11-lib jpeg
CMAKE_ARGS= -DVSP_USE_SYSTEM_CMINPACK:BOOLEAN=yes \
-DVSP_USE_SYSTEM_CPPTEST:BOOLEAN=yes \