aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/emacs20/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/emacs20/Makefile')
-rw-r--r--chinese/emacs20/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/chinese/emacs20/Makefile b/chinese/emacs20/Makefile
new file mode 100644
index 000000000000..a8b5afe4ebbc
--- /dev/null
+++ b/chinese/emacs20/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# Ports collection makefile for: emacs20 with XIM and a little zh-l10n
+# Date created: Sat Nov 11, 2000
+# Whom: Clive Lin <clive@CirX.ORG>
+#
+# $FreeBSD$
+#
+
+MASTERDIR= ${.CURDIR}/../../editors/emacs20
+
+MAINTAINER= clive@CirX.ORG
+
+.if !defined(WITHOUT_X11)
+RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/local/kc15f.pcf.gz:${PORTSDIR}/chinese/kcfonts \
+ xcin2.5:${PORTSDIR}/chinese/xcin25
+.endif
+
+WITH_XPG4= yes
+
+PKGMESSAGE= ${.CURDIR}/pkg-message
+
+PLIST= ${WRKDIR}/pkg-plist
+
+pre-patch:
+ @( cd ${WRKSRC}; \
+ ${PATCH} -sp1 < ${.CURDIR}/files/emacs20-xim-20000713.diff ; )
+
+post-patch:
+ @${ECHO} "share/emacs/%%EMACS_VER%%/etc/Emacs" >> ${WRKDIR}/pkg-plist
+ @${ECHO} "share/emacs/%%EMACS_VER%%/etc/dot.emacs" >> ${WRKDIR}/pkg-plist
+ @${CAT} ${MASTERDIR}/pkg-plist >> ${WRKDIR}/pkg-plist
+
+post-install:
+ ${INSTALL} -c ${.CURDIR}/files/Emacs ${PREFIX}/share/emacs/${PORTVERSION}/etc
+ ${INSTALL} -c ${.CURDIR}/files/dot.emacs ${PREFIX}/share/emacs/${PORTVERSION}/etc
+ @${CAT} ${PKGMESSAGE}
+
+.include "${MASTERDIR}/Makefile"