aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/fcitx-keyboard/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/fcitx-keyboard/Makefile')
-rw-r--r--chinese/fcitx-keyboard/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/chinese/fcitx-keyboard/Makefile b/chinese/fcitx-keyboard/Makefile
new file mode 100644
index 000000000000..f9c59138886f
--- /dev/null
+++ b/chinese/fcitx-keyboard/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: fcitx-keyboard
+# Date created: 6 Feb 2012
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fcitx-keyboard
+PORTVERSION= 0.1.0
+CATEGORIES= chinese
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DIST_SUBDIR= fcitx
+
+MAINTAINER= lichray@gmail.com
+COMMENT= X Keyboard Integration wtih Fcitx
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx \
+ enchant.1:${PORTSDIR}/textproc/enchant \
+ icuuc.48:${PORTSDIR}/devel/icu
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_CMAKE= yes
+USE_GNOME= libxml2
+USE_XORG= x11 xkbfile
+
+PROJECTHOST= fcitx
+
+.include <bsd.port.mk>