aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/gcin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/gcin/Makefile')
-rw-r--r--chinese/gcin/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/chinese/gcin/Makefile b/chinese/gcin/Makefile
index 892be468de35..e48c757ca606 100644
--- a/chinese/gcin/Makefile
+++ b/chinese/gcin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gcin
-PORTVERSION= 1.3.2
+PORTVERSION= 1.3.3
CATEGORIES= chinese textproc gnome
MASTER_SITES= http://cle.linux.org.tw/gcin/download/:main \
http://ftp.twaren.net/local-distfiles/gcin/:main \
@@ -42,15 +42,15 @@ post-extract:
> noseeing.cin
@${REINPLACE_CMD} -e 's,cj.gtab,cj.gtab noseeing.gtab,' \
${WRKSRC}/data/Makefile
+ @${REINPLACE_CMD} -e '/CJK/ d' ${WRKSRC}/data/noseeing.cin
.endif
pre-patch:
- ${MV} ${WRKSRC}/icons/3/pingin.png ${WRKSRC}/icons/3/pinyin.png
@${REINPLACE_CMD} -e 's,&,,; 1 s,bash,sh,; \
s,QT_IM_DIR=/usr,QT_IM_DIR=$$prefix,; \
s,mandir=$$datadir,mandir=$$prefix,; \
- s,/usr/share,$$prefix/share,; 164 s,/gcin,,; \
- 133,134 s,control-center-2\.0,gnome\/control-center-2\.0,g; \
+ s,/usr/share,$$prefix/share,; s,libdir)\/gcin,libdir),; \
+ 140 s,control-center-2\.0,gnome\/control-center-2\.0,g; \
s,gcc,$$CC,; s,gcin-$$GCIN_VERSION,gcin,' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's,\/usr\/share,$$(prefix)\/share,' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's,/usr/local,/usr,g' \
@@ -66,10 +66,10 @@ pre-patch:
@${REINPLACE_CMD} -e 's,gcin-im-client.h,im-client/gcin-im-client.h,' \
${WRKSRC}/gtk-im/gtkimcontextgcin.c
@${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},' \
- ${WRKSRC}/IMdkit/lib/Makefile \
- ${WRKSRC}/IMdkit/Xi18n_sample/Makefile ${WRKSRC}/Makefile \
+ ${WRKSRC}/IMdkit/lib/Makefile ${WRKSRC}/Makefile \
${WRKSRC}/qt-im/Makefile ${WRKSRC}/scripts/modify-XIM \
${WRKSRC}/scripts/utf8-edit
+ @${REINPLACE_CMD} -e '/make/ d' ${WRKSRC}/IMdkit/lib/Makefile
.if defined(WITH_BOSHIAMY)
post-patch: