aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/librime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/librime/Makefile')
-rw-r--r--chinese/librime/Makefile36
1 files changed, 9 insertions, 27 deletions
diff --git a/chinese/librime/Makefile b/chinese/librime/Makefile
index 637d444ccf3a..b76aabb88188 100644
--- a/chinese/librime/Makefile
+++ b/chinese/librime/Makefile
@@ -2,14 +2,13 @@
# $FreeBSD$
PORTNAME= librime
-PORTVERSION= 0.9.7
-PORTREVISION= 2
+PORTVERSION= 1.1
CATEGORIES= chinese textproc
-MASTER_SITES= GOOGLE_CODE
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} brise-${DATA_VER}.tar.gz
+MASTER_SITES= http://github.com/rime/${PORTNAME}/archive/rime-${PORTVERSION}.tar.gz?dummy=/
+DISTNAME= ${PORTNAME}-rime-${DISTVERSION}
MAINTAINER= lichray@gmail.com
-COMMENT= Rime Input Method Engine
+COMMENT= Rime Input Method Engine, the core library
LICENSE= GPLv3
@@ -17,37 +16,20 @@ LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libglog.so:${PORTSDIR}/devel/glog \
libkyotocabinet.so:${PORTSDIR}/databases/kyotocabinet \
libopencc.so:${PORTSDIR}/chinese/opencc \
- libyaml-cpp03.so:${PORTSDIR}/devel/yaml-cpp03
+ libyaml-cpp.so:${PORTSDIR}/devel/yaml-cpp
-USES= cmake pkgconfig gettext perl5
+USES= cmake compiler:c++11-lang pkgconfig gettext perl5
USE_PERL5= build patch
USE_LDCONFIG= yes
USE_XORG= xproto
LDFLAGS+= -lintl
-PLIST_SUB= VER=${PORTVERSION}
+PLIST_SUB= VER=${PORTVERSION}.0
+
+.include <bsd.port.options.mk>
post-patch: .SILENT
${FIND} ${WRKSRC} \( -name '*.cc' -or -name '*.h' \) \
-exec ${PERL} -i -pe '$$. == 1 && s/^\xef\xbb\xbf//;' '{}' \;
- ${REINPLACE_CMD} -e 's|yaml-cpp|&03|g' ${WRKSRC}/cmake/FindYamlCpp.cmake \
- ${WRKSRC}/src/config.cc ${WRKSRC}/src/dict/dict_settings.cc
-
-post-build:
- @echo "building rime data."
- @${MKDIR} ${DATASRC}
- @(cd ${WRKDIR}/brise; ${CP} \
- default.yaml essay.kct supplement/*.yaml preset/*.yaml ${DATASRC})
- ${WRKSRC}/bin/rime_deployer --build ${DATASRC}
-
-post-install:
- ${MKDIR} ${STAGEDIR}${DATADIR}/data
- ${INSTALL_DATA} ${DATASRC}/*.kct ${DATASRC}/*.bin ${STAGEDIR}${DATADIR}/data/
-
-PROJECTHOST= rimeime
-DATA_VER= 0.16
-WRKSRC= ${WRKDIR}/${PORTNAME}
-DATASRC= ${WRKDIR}/tmp
-DATADIR= ${PREFIX}/share/rime
.include <bsd.port.mk>