aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/mutt
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/mutt')
-rw-r--r--chinese/mutt/Makefile2
-rw-r--r--chinese/mutt/files/patch-zh-mutt112
2 files changed, 57 insertions, 57 deletions
diff --git a/chinese/mutt/Makefile b/chinese/mutt/Makefile
index afa828d86d35..da15002c2b90 100644
--- a/chinese/mutt/Makefile
+++ b/chinese/mutt/Makefile
@@ -10,7 +10,7 @@ PORTREVISION= 1
CATEGORIES= chinese
MASTERDIR= ${.CURDIR}/../../mail/mutt-devel
-REVISEDATE= 20080522
+REVISEDATE= 20090211
PORTREVISION= ${REVISEDATE}
# XXX: Currently PORTREVISION assignment is not perfect. It needs to
diff --git a/chinese/mutt/files/patch-zh-mutt b/chinese/mutt/files/patch-zh-mutt
index 1ff11d78a478..ea7d6be3a691 100644
--- a/chinese/mutt/files/patch-zh-mutt
+++ b/chinese/mutt/files/patch-zh-mutt
@@ -1,9 +1,9 @@
-diff -ruN mutt-1.5.18.orig/init.h init.h
---- mutt-1.5.18.orig/init.h 2008-05-22 09:18:39.000000000 +0800
-+++ init.h 2008-05-22 09:18:46.000000000 +0800
-@@ -270,6 +270,11 @@
- ** unset, you must first use the tag-prefix function (default: ";") to
- ** make the next function apply to all tagged messages.
+diff -ruN mutt-1.5.19.orig/init.h init.h
+--- mutt-1.5.19.orig/init.h 2009-02-11 11:57:36.000000000 +0800
++++ init.h 2009-02-11 11:57:40.000000000 +0800
+@@ -279,6 +279,11 @@
+ ** unset, you must first use the \fC<tag-prefix>\fP function (bound to ``;''
+ ** by default) to make the next function apply to all tagged messages.
*/
+ { "bbsislame", DT_BOOL, R_NONE, OPTBBSISLAME, 0 },
+ /*
@@ -13,7 +13,7 @@ diff -ruN mutt-1.5.18.orig/init.h init.h
{ "beep", DT_BOOL, R_NONE, OPTBEEP, 1 },
/*
** .pp
-@@ -2521,7 +2526,7 @@
+@@ -2681,7 +2686,7 @@
** mutt scores are always greater than or equal to zero, the default setting
** of this variable will never mark a message read.
*/
@@ -22,7 +22,7 @@ diff -ruN mutt-1.5.18.orig/init.h init.h
/*
** .pp
** A colon-delimited list of character sets for outgoing messages. Mutt will use the
-@@ -2964,7 +2969,7 @@
+@@ -3143,7 +3148,7 @@
** machine without having to enter a password.
*/
#endif
@@ -31,9 +31,9 @@ diff -ruN mutt-1.5.18.orig/init.h init.h
/*
** .pp
** \fBWarning:\fP do not set this variable unless you are using a version
-diff -ruN mutt-1.5.18.orig/mbyte.c mbyte.c
---- mutt-1.5.18.orig/mbyte.c 2008-05-22 09:18:39.000000000 +0800
-+++ mbyte.c 2008-05-22 09:18:46.000000000 +0800
+diff -ruN mutt-1.5.19.orig/mbyte.c mbyte.c
+--- mutt-1.5.19.orig/mbyte.c 2009-02-11 11:57:36.000000000 +0800
++++ mbyte.c 2009-02-11 11:57:40.000000000 +0800
@@ -24,6 +24,9 @@
# include "config.h"
#endif
@@ -93,7 +93,7 @@ diff -ruN mutt-1.5.18.orig/mbyte.c mbyte.c
return (9 <= wc && wc <= 13) || wc == 32;
else
return (0 <= wc && wc < 256) ? isspace (wc) : 0;
-@@ -315,7 +328,7 @@
+@@ -345,7 +358,7 @@
wint_t towupper (wint_t wc)
{
@@ -102,7 +102,7 @@ diff -ruN mutt-1.5.18.orig/mbyte.c mbyte.c
return towupper_ucs (wc);
else
return (0 <= wc && wc < 256) ? toupper (wc) : wc;
-@@ -323,7 +336,7 @@
+@@ -353,7 +366,7 @@
wint_t towlower (wint_t wc)
{
@@ -111,7 +111,7 @@ diff -ruN mutt-1.5.18.orig/mbyte.c mbyte.c
return towlower_ucs (wc);
else
return (0 <= wc && wc < 256) ? tolower (wc) : wc;
-@@ -331,7 +344,7 @@
+@@ -361,7 +374,7 @@
int iswalnum (wint_t wc)
{
@@ -120,7 +120,7 @@ diff -ruN mutt-1.5.18.orig/mbyte.c mbyte.c
return iswalnum_ucs (wc);
else
return (0 <= wc && wc < 256) ? isalnum (wc) : 0;
-@@ -356,13 +369,31 @@
+@@ -402,13 +415,31 @@
return -1;
}
@@ -153,7 +153,7 @@ diff -ruN mutt-1.5.18.orig/mbyte.c mbyte.c
{
/* 8-bit case */
if (!wc)
-@@ -372,13 +403,6 @@
+@@ -418,13 +449,6 @@
else
return -1;
}
@@ -167,10 +167,10 @@ diff -ruN mutt-1.5.18.orig/mbyte.c mbyte.c
}
return wcwidth_ucs (wc);
}
-diff -ruN mutt-1.5.18.orig/mutt.h mutt.h
---- mutt-1.5.18.orig/mutt.h 2008-05-22 09:18:39.000000000 +0800
-+++ mutt.h 2008-05-22 09:18:46.000000000 +0800
-@@ -335,6 +335,7 @@
+diff -ruN mutt-1.5.19.orig/mutt.h mutt.h
+--- mutt-1.5.19.orig/mutt.h 2009-02-11 11:57:36.000000000 +0800
++++ mutt.h 2009-02-11 11:57:40.000000000 +0800
+@@ -315,6 +315,7 @@
OPTATTACHSPLIT,
OPTAUTOEDIT,
OPTAUTOTAG,
@@ -178,9 +178,9 @@ diff -ruN mutt-1.5.18.orig/mutt.h mutt.h
OPTBEEP,
OPTBEEPNEW,
OPTBOUNCEDELIVERED,
-diff -ruN mutt-1.5.18.orig/myiconv.c myiconv.c
---- mutt-1.5.18.orig/myiconv.c 1970-01-01 08:00:00.000000000 +0800
-+++ myiconv.c 2008-05-22 09:18:46.000000000 +0800
+diff -ruN mutt-1.5.19.orig/myiconv.c myiconv.c
+--- mutt-1.5.19.orig/myiconv.c 1970-01-01 08:00:00.000000000 +0800
++++ myiconv.c 2009-02-11 11:57:40.000000000 +0800
@@ -0,0 +1,167 @@
+/*
+ * Contributed by Kuang-che Wu <kcwu@kcwu.dyndns.org>
@@ -349,9 +349,9 @@ diff -ruN mutt-1.5.18.orig/myiconv.c myiconv.c
+}
+
+#endif
-diff -ruN mutt-1.5.18.orig/pager.c pager.c
---- mutt-1.5.18.orig/pager.c 2008-05-22 09:18:39.000000000 +0800
-+++ pager.c 2008-05-22 09:18:46.000000000 +0800
+diff -ruN mutt-1.5.19.orig/pager.c pager.c
+--- mutt-1.5.19.orig/pager.c 2009-02-11 11:57:36.000000000 +0800
++++ pager.c 2009-02-11 11:57:40.000000000 +0800
@@ -20,6 +20,10 @@
# include "config.h"
#endif
@@ -363,7 +363,7 @@ diff -ruN mutt-1.5.18.orig/pager.c pager.c
#include "mutt.h"
#include "mutt_curses.h"
#include "mutt_regex.h"
-@@ -1062,7 +1066,7 @@
+@@ -1055,7 +1059,7 @@
{
int space = -1; /* index of the last space or TAB */
int col = option (OPTMARKERS) ? (*lineInfo)[n].continuation : 0;
@@ -372,7 +372,7 @@ diff -ruN mutt-1.5.18.orig/pager.c pager.c
wchar_t wc;
mbstate_t mbstate;
-@@ -1154,7 +1158,10 @@
+@@ -1153,7 +1157,10 @@
{
if (wc == ' ')
space = ch;
@@ -383,7 +383,7 @@ diff -ruN mutt-1.5.18.orig/pager.c pager.c
if (col + t > wrap_cols)
break;
col += t;
-@@ -1371,6 +1378,7 @@
+@@ -1370,6 +1377,7 @@
{
buf_ptr = buf + ch;
/* skip trailing blanks */
@@ -391,25 +391,25 @@ diff -ruN mutt-1.5.18.orig/pager.c pager.c
while (ch && (buf[ch] == ' ' || buf[ch] == '\t' || buf[ch] == '\r'))
ch--;
/* a very long word with leading spaces causes infinite wrapping */
-diff -ruN mutt-1.5.18.orig/parse.c parse.c
---- mutt-1.5.18.orig/parse.c 2008-05-22 09:18:39.000000000 +0800
-+++ parse.c 2008-05-22 09:18:46.000000000 +0800
-@@ -426,7 +426,10 @@
+diff -ruN mutt-1.5.19.orig/parse.c parse.c
+--- mutt-1.5.19.orig/parse.c 2009-02-11 11:57:36.000000000 +0800
++++ parse.c 2009-02-11 11:57:54.000000000 +0800
+@@ -381,7 +381,10 @@
s++;
SKIPWS (s);
- if ((s = mutt_get_parameter ("filename", (parms = parse_parameters (s)))) != 0)
+ if ((s = mutt_get_parameter ("filename", (parms = parse_parameters (s)))))
- mutt_str_replace (&ct->filename, s);
-+ {
-+ mutt_str_replace (&ct->filename, s);
-+ rfc2047_decode (&ct->filename);
-+ }
- if ((s = mutt_get_parameter ("name", parms)) != 0)
++ {
++ mutt_str_replace (&ct->filename, s);
++ rfc2047_decode (&ct->filename);
++ }
+ if ((s = mutt_get_parameter ("name", parms)))
ct->form_name = safe_strdup (s);
mutt_free_parameter (&parms);
-diff -ruN mutt-1.5.18.orig/pgp.c pgp.c
---- mutt-1.5.18.orig/pgp.c 2008-05-22 09:18:39.000000000 +0800
-+++ pgp.c 2008-05-22 09:18:46.000000000 +0800
-@@ -1001,7 +1001,7 @@
+diff -ruN mutt-1.5.19.orig/pgp.c pgp.c
+--- mutt-1.5.19.orig/pgp.c 2009-02-11 11:57:36.000000000 +0800
++++ pgp.c 2009-02-11 11:57:40.000000000 +0800
+@@ -1006,7 +1006,7 @@
int empty = 1;
pid_t thepid;
@@ -418,10 +418,10 @@ diff -ruN mutt-1.5.18.orig/pgp.c pgp.c
mutt_mktemp (sigfile);
if ((fp = safe_fopen (sigfile, "w")) == NULL)
-diff -ruN mutt-1.5.18.orig/po/zh_TW.po po/zh_TW.po
---- mutt-1.5.18.orig/po/zh_TW.po 2008-05-22 09:18:39.000000000 +0800
-+++ po/zh_TW.po 2008-05-22 09:19:25.000000000 +0800
-@@ -1768,7 +1768,7 @@
+diff -ruN mutt-1.5.19.orig/po/zh_TW.po po/zh_TW.po
+--- mutt-1.5.19.orig/po/zh_TW.po 2009-02-11 11:57:36.000000000 +0800
++++ po/zh_TW.po 2009-02-11 11:57:40.000000000 +0800
+@@ -1777,7 +1777,7 @@
"~w 檔案\t\t將訊息寫入檔案\n"
"~x\t\t停止修改並離開編輯器\n"
"~?\t\t這訊息\n"
@@ -430,7 +430,7 @@ diff -ruN mutt-1.5.18.orig/po/zh_TW.po po/zh_TW.po
#: edit.c:52
#, fuzzy
-@@ -1800,7 +1800,7 @@
+@@ -1809,7 +1809,7 @@
"~w 檔案\t\t將訊息寫入檔案\n"
"~x\t\t停止修改並離開編輯器\n"
"~?\t\t這訊息\n"
@@ -439,7 +439,7 @@ diff -ruN mutt-1.5.18.orig/po/zh_TW.po po/zh_TW.po
#: edit.c:188
#, c-format
-@@ -1809,7 +1809,7 @@
+@@ -1818,7 +1818,7 @@
#: edit.c:330
msgid "(End message with a . on a line by itself)\n"
@@ -448,7 +448,7 @@ diff -ruN mutt-1.5.18.orig/po/zh_TW.po po/zh_TW.po
#: edit.c:389
msgid "No mailbox.\n"
-@@ -4509,7 +4509,7 @@
+@@ -4565,7 +4565,7 @@
#: ../keymap_alldefs.h:43
msgid "rename/move an attached file"
@@ -457,7 +457,7 @@ diff -ruN mutt-1.5.18.orig/po/zh_TW.po po/zh_TW.po
#: ../keymap_alldefs.h:44
msgid "send the message"
-@@ -4517,7 +4517,7 @@
+@@ -4573,7 +4573,7 @@
#: ../keymap_alldefs.h:45
msgid "toggle disposition between inline/attachment"
@@ -466,7 +466,7 @@ diff -ruN mutt-1.5.18.orig/po/zh_TW.po po/zh_TW.po
#: ../keymap_alldefs.h:46
msgid "toggle whether to delete file after sending it"
-@@ -5127,11 +5127,11 @@
+@@ -5183,11 +5183,11 @@
#: ../keymap_alldefs.h:195
msgid "Select the previous element of the chain"
@@ -480,10 +480,10 @@ diff -ruN mutt-1.5.18.orig/po/zh_TW.po po/zh_TW.po
#: ../keymap_alldefs.h:197
msgid "send the message through a mixmaster remailer chain"
-diff -ruN mutt-1.5.18.orig/sendlib.c sendlib.c
---- mutt-1.5.18.orig/sendlib.c 2008-05-22 09:18:39.000000000 +0800
-+++ sendlib.c 2008-05-22 09:18:46.000000000 +0800
-@@ -2344,7 +2344,7 @@
+diff -ruN mutt-1.5.19.orig/sendlib.c sendlib.c
+--- mutt-1.5.19.orig/sendlib.c 2009-02-11 11:57:36.000000000 +0800
++++ sendlib.c 2009-02-11 11:57:40.000000000 +0800
+@@ -2289,7 +2289,7 @@
rfc2047_encode_adrlist (env->reply_to, "Reply-To");
rfc2047_encode_string (&env->x_label);