aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/oicq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/oicq/Makefile')
-rw-r--r--chinese/oicq/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/chinese/oicq/Makefile b/chinese/oicq/Makefile
new file mode 100644
index 000000000000..8432ea85ee54
--- /dev/null
+++ b/chinese/oicq/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: zh-oicq
+# Date created: 10 Nov 2003
+# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oicq
+PORTVERSION= 1.3
+CATEGORIES= chinese net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= perl-oicq
+DISTNAME= Net-OICQ-${PORTVERSION}
+
+MAINTAINER= bg1tpt@gmail.com
+COMMENT= Implements OICQ messaging protocol
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/Crypt/OICQ.pm:${PORTSDIR}/security/p5-Crypt-OICQ
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::OICQ.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800 # inherits from security/p5-Crypt-OICQ
+IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/qq ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/demo1 ${PREFIX}/bin/qq-demo1
+
+.include <bsd.port.post.mk>