aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/xpdf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/xpdf/Makefile')
-rw-r--r--chinese/xpdf/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/chinese/xpdf/Makefile b/chinese/xpdf/Makefile
index 7c9f573e6cd5..58fa622aee05 100644
--- a/chinese/xpdf/Makefile
+++ b/chinese/xpdf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xpdf
PORTVERSION= 20040727
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= chinese graphics print
MASTER_SITES= ftp://ftp.foolabs.com/pub/xpdf/ \
${MASTER_SITE_TEX_CTAN} \
@@ -20,16 +20,21 @@ MAINTAINER= dryice@dryice.name
COMMENT= Chinese xpdf font support
RUN_DEPENDS= xpdf:${PORTSDIR}/graphics/xpdf\
- ${LOCALBASE}/share/ghostscript/Resource/CMap/Adobe-CNS1-0:${PORTSDIR}/print/adobe-cmaps \
+ ${ADOBECMAPDIR}/ai0/CMap/Identity-H:${PORTSDIR}/print/adobe-cmaps \
${LOCALBASE}/share/arphicttf/logo.gif:${PORTSDIR}/chinese/arphicttf
NO_BUILD= yes
USE_X_PREFIX= yes
NO_WRKSUBDIR= yes
+SUB_FILES= dot.xpdfrc
+SUB_LIST= ADOBECMAPDIR=${ADOBECMAPDIR}
+
SIMP_FILES= Adobe-GB1.cidToUnicode EUC-CN.unicodeMap GBK.unicodeMap \
ISO-2022-CN.unicodeMap README
TRAD_FILES= Adobe-CNS1.cidToUnicode Big5.unicodeMap \
Big5ascii.unicodeMap README
+ADOBECMAPDIR= ${LOCALBASE}/share/fonts/adobe-cmaps
+
do-install:
@${MKDIR} ${DATADIR}/chinese-simplified
.for i in ${SIMP_FILES}
@@ -39,7 +44,7 @@ do-install:
.for i in ${TRAD_FILES}
${INSTALL_DATA} ${WRKSRC}/xpdf-chinese-traditional/${i} ${DATADIR}/chinese-traditional
.endfor
- ${INSTALL_DATA} ${FILESDIR}/dot.xpdfrc ${DATADIR}/chinese-traditional
+ ${INSTALL_DATA} ${WRKSRC}/dot.xpdfrc ${DATADIR}/chinese-traditional
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>