aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/fcitx-keyboard/Makefile30
-rw-r--r--chinese/fcitx-keyboard/distinfo2
-rw-r--r--chinese/fcitx-keyboard/pkg-descr4
-rw-r--r--chinese/fcitx-keyboard/pkg-plist8
5 files changed, 45 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 4a41b632903d..8daa65d72669 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -40,6 +40,7 @@
SUBDIR += fcitx-cloudpinyin
SUBDIR += fcitx-configtool
SUBDIR += fcitx-googlepinyin
+ SUBDIR += fcitx-keyboard
SUBDIR += fcitx-sunpinyin
SUBDIR += fcitx-ui-light
SUBDIR += fireflyttf
diff --git a/chinese/fcitx-keyboard/Makefile b/chinese/fcitx-keyboard/Makefile
new file mode 100644
index 000000000000..f9c59138886f
--- /dev/null
+++ b/chinese/fcitx-keyboard/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: fcitx-keyboard
+# Date created: 6 Feb 2012
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fcitx-keyboard
+PORTVERSION= 0.1.0
+CATEGORIES= chinese
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DIST_SUBDIR= fcitx
+
+MAINTAINER= lichray@gmail.com
+COMMENT= X Keyboard Integration wtih Fcitx
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx \
+ enchant.1:${PORTSDIR}/textproc/enchant \
+ icuuc.48:${PORTSDIR}/devel/icu
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_CMAKE= yes
+USE_GNOME= libxml2
+USE_XORG= x11 xkbfile
+
+PROJECTHOST= fcitx
+
+.include <bsd.port.mk>
diff --git a/chinese/fcitx-keyboard/distinfo b/chinese/fcitx-keyboard/distinfo
new file mode 100644
index 000000000000..72c84b46a3d0
--- /dev/null
+++ b/chinese/fcitx-keyboard/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fcitx/fcitx-keyboard-0.1.0.tar.bz2) = 09813e57cdebe24c6405b0fcef3b72e045b58c527c733dbc45689fcc3cef0c13
+SIZE (fcitx/fcitx-keyboard-0.1.0.tar.bz2) = 45518
diff --git a/chinese/fcitx-keyboard/pkg-descr b/chinese/fcitx-keyboard/pkg-descr
new file mode 100644
index 000000000000..d55a37957b01
--- /dev/null
+++ b/chinese/fcitx-keyboard/pkg-descr
@@ -0,0 +1,4 @@
+fcitx-keyboard provides an input method featuring word completion
+based on different keyboard layouts.
+
+WWW: http://code.google.com/p/fcitx/
diff --git a/chinese/fcitx-keyboard/pkg-plist b/chinese/fcitx-keyboard/pkg-plist
new file mode 100644
index 000000000000..21945f435ed8
--- /dev/null
+++ b/chinese/fcitx-keyboard/pkg-plist
@@ -0,0 +1,8 @@
+lib/fcitx/fcitx-keyboard.so
+lib/fcitx/fcitx-xkb.so
+share/fcitx/addon/fcitx-keyboard.conf
+share/fcitx/addon/fcitx-xkb.conf
+share/fcitx/configdesc/fcitx-keyboard.desc
+share/fcitx/configdesc/fcitx-xkb.desc
+share/locale/zh_CN/LC_MESSAGES/fcitx-keyboard.mo
+share/locale/zh_TW/LC_MESSAGES/fcitx-keyboard.mo