aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/cconv/Makefile23
-rw-r--r--chinese/cconv/distinfo2
-rw-r--r--chinese/cconv/pkg-descr13
-rw-r--r--chinese/cconv/pkg-plist7
5 files changed, 46 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 19480273d9b1..b5226953f03a 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -22,6 +22,7 @@
SUBDIR += bug5
SUBDIR += c2t
SUBDIR += cce
+ SUBDIR += cconv
SUBDIR += celvis
SUBDIR += chm2html
SUBDIR += cless
diff --git a/chinese/cconv/Makefile b/chinese/cconv/Makefile
new file mode 100644
index 000000000000..c9f7bc41e78d
--- /dev/null
+++ b/chinese/cconv/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: cconv
+# Date created: 2011-04-26
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cconv
+PORTVERSION= 0.6.2
+CATEGORIES= chinese converters
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simplified-Traditional Chinese conversion tool
+
+GNU_CONFIGURE= yes
+USE_ICONV= yes
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|UTF-TW|UTF8-TW|g' ${WRKSRC}/main.c
+
+.include <bsd.port.mk>
diff --git a/chinese/cconv/distinfo b/chinese/cconv/distinfo
new file mode 100644
index 000000000000..81a1cb4e1201
--- /dev/null
+++ b/chinese/cconv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cconv-0.6.2.tar.gz) = f463da66c2ae18407441e12716f5f1c6cdea4e417ebfd475ec4c6dc6ad250c9d
+SIZE (cconv-0.6.2.tar.gz) = 538414
diff --git a/chinese/cconv/pkg-descr b/chinese/cconv/pkg-descr
new file mode 100644
index 000000000000..e8067a2c9e8e
--- /dev/null
+++ b/chinese/cconv/pkg-descr
@@ -0,0 +1,13 @@
+cconv (pronunciation: see-conv.) is iconv based simplified-traditional chinese
+conversion tool. It is NOT only transcoding programm, but also TRANSLATE tools
+between the Simplified Chinese and Traditional Chinese.
+
+We stand on the shoulders of giants, cconv source code is based on iconv a
+excellent program converts text from one encoding to another encoding.
+
+Features:
+- iconv liked usage.
+- language level simplified-traditional chinese.
+- idioms can be translated.
+
+WWW: http://code.google.com/p/cconv/
diff --git a/chinese/cconv/pkg-plist b/chinese/cconv/pkg-plist
new file mode 100644
index 000000000000..950de771d293
--- /dev/null
+++ b/chinese/cconv/pkg-plist
@@ -0,0 +1,7 @@
+bin/cconv
+include/cconv.h
+include/unicode.h
+lib/libcconv.a
+lib/libcconv.la
+lib/libcconv.so
+lib/libcconv.so.0