aboutsummaryrefslogtreecommitdiffstats
path: root/comms/gnokii/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/gnokii/Makefile')
-rw-r--r--comms/gnokii/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index b324374e071e..4421dbaee7c7 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnokii
-PORTVERSION= 0.6.3
+PORTVERSION= 0.6.4
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
@@ -68,8 +68,12 @@ WITH_PGSQL= yes
.else
PLIST_SUB+= PGM='@comment '
.endif
+.if defined(SMSD_WITH_GLIB2)
+USE_GNOME+= glib20
+.else
USE_GNOME+= glib12
.endif
+.endif
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --without-x
@@ -90,6 +94,7 @@ PLIST_SUB+= NLS="@comment "
.endif
pre-fetch:
+.if !defined(WITH_SMSD)
@${ECHO}
@${ECHO} "If you plan using the smsd daemon for automatically receiving,"
@${ECHO} "managing and sending SMSes define WITH_SMSD=yes."
@@ -98,6 +103,13 @@ pre-fetch:
@${ECHO} "will be automatically compiled in. Normal file systems support is"
@${ECHO} "always compiled in."
@${ECHO}
+.endif
+.if !defined(SMSD_WITH_GLIB2)
+ @${ECHO}
+ @${ECHO} "smsd defaults to using glib1, if you'd rather link with glib2
+ @${ECHO} "define SMSD_WITH_GLIB2=yes"
+ @${ECHO}
+.endif
post-patch:
.for f in ${FIXPREFIX}
@@ -114,6 +126,9 @@ post-patch:
@${FIND} ${WRKSRC} -type f -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} \
-e 's|<stdint.h>|<inttypes.h>|'
.endif
+.if defined(SMSD_WITH_GLIB2)
+ @cd ${WRKSRC} && ${PATCH} -s <${PATCHDIR}/smsd-Makefile-WITH_GLIB.diff
+.endif
post-build:
.if defined(WITH_SMSD)