aboutsummaryrefslogtreecommitdiffstats
path: root/comms/hidapi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/hidapi/Makefile')
-rw-r--r--comms/hidapi/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/comms/hidapi/Makefile b/comms/hidapi/Makefile
index b02f8141712e..29012fee3c82 100644
--- a/comms/hidapi/Makefile
+++ b/comms/hidapi/Makefile
@@ -15,10 +15,16 @@ LICENSE_COMB= dual
USE_GITHUB= yes
GH_ACCOUNT= signal11
-USES= autoreconf iconv:wchar_t libtool
+USES= autoreconf gettext-tools iconv:wchar_t libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
PORTDOCS= *
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+
+pre-configure:
+ @${CP} ${LOCALBASE}/share/gettext/config.rpath ${WRKSRC}
+
.include <bsd.port.mk>