aboutsummaryrefslogtreecommitdiffstats
path: root/comms/openobex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/openobex/Makefile')
-rw-r--r--comms/openobex/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/comms/openobex/Makefile b/comms/openobex/Makefile
index 790d2a2ef3e6..9bfb750c1f05 100644
--- a/comms/openobex/Makefile
+++ b/comms/openobex/Makefile
@@ -24,9 +24,13 @@ OPTIONS= LIBUSB "Enable OBEX over USB" no
.include <bsd.port.pre.mk>
.if defined(WITH_LIBUSB)
+. if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
-CONFIGURE_ARGS+=--enable-usb
CFLAGS+= -I${PREFIX}/include
+. else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure
+. endif
+CONFIGURE_ARGS+=--enable-usb
.else
CONFIGURE_ARGS+=--disable-usb
.endif