aboutsummaryrefslogtreecommitdiffstats
path: root/comms/p5-Device-Modem/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/p5-Device-Modem/Makefile')
-rw-r--r--comms/p5-Device-Modem/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/comms/p5-Device-Modem/Makefile b/comms/p5-Device-Modem/Makefile
new file mode 100644
index 000000000000..a2ac2f6b5196
--- /dev/null
+++ b/comms/p5-Device-Modem/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Device-Modem
+# Date created: 22 July 2003
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Device-Modem
+PORTVERSION= 1.28
+CATEGORIES= comms perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Device
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Perl class to interface generic modems (AT-compliant)
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Device/SerialPort.pm:${PORTSDIR}/comms/p5-Device-SerialPort
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Device::Modem::Log::File.3 Device::Modem::Log::Syslog.3 Device::Modem.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d -m 0755 ${DOCSDIR}/examples
+ ${INSTALL_DATA} ${WRKSRC}/examples/active.pl ${DOCSDIR}/examples/
+ ${INSTALL_DATA} ${WRKSRC}/examples/dial.pl ${DOCSDIR}/examples/
+ ${INSTALL_DATA} ${WRKSRC}/examples/shell.pl ${DOCSDIR}/examples/
+.endif
+
+.include <bsd.port.mk>