aboutsummaryrefslogtreecommitdiffstats
path: root/comms/pstngw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/pstngw/Makefile')
-rw-r--r--comms/pstngw/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/comms/pstngw/Makefile b/comms/pstngw/Makefile
new file mode 100644
index 000000000000..d2c5d30695c4
--- /dev/null
+++ b/comms/pstngw/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: pstngw
+# Date created: Wed Apr 15 15:41:00 GMT 2000
+# Whom: Jakub Klausa <jacke@bofh.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pstngw
+PORTVERSION= 1.2.2
+CATEGORIES= comms
+MASTER_SITES= http://www.openh323.org/bin/
+DISTNAME= pstngw_${PORTVERSION}
+
+MAINTAINER= jacke@bofh.pl
+COMMENT= Simple H.323-PSTN (POTS) gateway
+
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/openh323:build
+
+NOCLEANDEPENDS= yes
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/pstngw
+MAKE_ENV+= PWLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib \
+ OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../../net/openh323/work/openh323
+THE_MACHTYPE= ${ARCH:S/i386/x86/}
+
+PLIST_FILES= bin/pstngw
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_d/pstngw ${PREFIX}/bin
+
+.include <bsd.port.mk>