aboutsummaryrefslogtreecommitdiffstats
path: root/comms/smstools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/smstools/Makefile')
-rw-r--r--comms/smstools/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/comms/smstools/Makefile b/comms/smstools/Makefile
index 6038a836e8ca..16358199b5c7 100644
--- a/comms/smstools/Makefile
+++ b/comms/smstools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= smstools
PORTVERSION= 2.0.7
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= http://www.meinemullemaus.de/software/smstools/packages/
@@ -18,19 +19,12 @@ LIB_DEPENDS= mm:${PORTSDIR}/devel/mm
WRKSRC= ${WRKDIR}/smstools
USE_GMAKE= yes
USE_RC_SUBR= smsd.sh
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR} \
- EXAMPLESDIR=${EXAMPLESDIR}
post-patch:
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/smsd.sh.in > ${WRKDIR}/smsd.sh
- @${REINPLACE_CMD} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ @${REINPLACE_CMD} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${WRKSRC}/src/smsd_cfg.c \
${WRKSRC}/install.sh \
${WRKSRC}/examples/smsd.conf.easy \
${WRKSRC}/examples/smsd.conf.full
-post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/smsd.sh ${PREFIX}/etc/rc.d/smsd.sh
-
.include <bsd.port.mk>