aboutsummaryrefslogtreecommitdiffstats
path: root/comms/unixcw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/unixcw/Makefile')
-rw-r--r--comms/unixcw/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/comms/unixcw/Makefile b/comms/unixcw/Makefile
new file mode 100644
index 000000000000..0c0f8cf6e67e
--- /dev/null
+++ b/comms/unixcw/Makefile
@@ -0,0 +1,56 @@
+# ports collection makefile for: unixcw
+# Date created: 24 Dec 2007
+# Whom: Diane Bruce <db@db.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unixcw
+PORTVERSION= 2.3
+CATEGORIES= comms hamradio
+MASTER_SITES= http://www.ibiblio.org/pub/linux/apps/ham/morse/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= db@FreeBSD.org
+COMMENT= Libs for cw on unix
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --includedir="${LOCALBASE}/include" \
+ --libdir="${LOCALBASE}/lib"
+MAN1= cw.1 cwgen.1 cwcp.1
+MAN3= cwlib.3
+.if defined(WITH_XCWCP)
+MAN1+= xcwcp.1
+USE_QT_VER= 3
+CONFIGURE_ARGS+= QTLIB=qt-mt
+PLIST_SUB+= XCWCP=""
+.else
+PLIST_SUB+= XCWCP="@comment "
+.endif
+MAN7= cw.7 CW.7
+MANCOMPRESSED= yes
+USE_AUTOTOOLS= autoconf:261
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 600000
+BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
+.endif
+
+pre-extract:
+.if !defined(WITH_XCWCP)
+ @${ECHO_CMD}
+ @${ECHO_CMD} "****** To build xcwcp, interrupt the build ******"
+ @${ECHO_CMD} "****** now, set WITH_XCWCP and start again. ******"
+ @${ECHO_CMD}
+ @sleep 3
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%LIBDATA%%|${PREFIX}/libdata|" \
+ ${WRKSRC}/src/cwlib/Makefile
+
+.include <bsd.port.post.mk>