aboutsummaryrefslogtreecommitdiffstats
path: root/comms/wwl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/wwl/Makefile')
-rw-r--r--comms/wwl/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/comms/wwl/Makefile b/comms/wwl/Makefile
index 2bffbb4710ac..da61d86c0629 100644
--- a/comms/wwl/Makefile
+++ b/comms/wwl/Makefile
@@ -13,19 +13,13 @@ MAINTAINER= db@FreeBSD.org
COMMENT= Calculates distance (qrb) used in Amateur Radio
CONFLICTS= locator*
-PORTDOCS= INSTALL
-PLIST_FILES= bin/wwl bin/locator
-MAN1= wwl.1
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/wwl ${PREFIX}/bin
- ${RM} -f ${PREFIX}/bin/locator
- ${LN} ${PREFIX}/bin/wwl ${PREFIX}/bin/locator
- ${INSTALL_DATA} ${WRKSRC}/wwl.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCSDIR}
-.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/wwl ${STAGEDIR}${PREFIX}/bin
+ @${RM} -f ${STAGEDIR}${PREFIX}/bin/locator
+ @${LN} -sf wwl ${STAGEDIR}${PREFIX}/bin/locator
+ @${INSTALL_DATA} ${WRKSRC}/wwl.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/INSTALL ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>