aboutsummaryrefslogtreecommitdiffstats
path: root/comms/xastir
diff options
context:
space:
mode:
Diffstat (limited to 'comms/xastir')
-rw-r--r--comms/xastir/Makefile38
-rw-r--r--comms/xastir/distinfo6
-rw-r--r--comms/xastir/files/patch-main.c11
3 files changed, 24 insertions, 31 deletions
diff --git a/comms/xastir/Makefile b/comms/xastir/Makefile
index ae8b3b0f07d1..2723659c047a 100644
--- a/comms/xastir/Makefile
+++ b/comms/xastir/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xastir
-PORTVERSION= 1.8.2
-PORTREVISION= 1
+PORTVERSION= 1.8.4
CATEGORIES= comms hamradio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xastir
@@ -34,6 +33,7 @@ OPTIONS= SHAPELIB "Include Shapelib support" On \
DBFAWK "Include DBFAWK Support" On \
MAGICK "Include ImageMagick Support" On \
CURL "Include CURL Internet Image support" On \
+ GEOTIFF "Include GeoTIFF Support" Off \
GDAL "Include GDAL Support" Off \
GPSMAN "Include GPSMAN Support" Off \
FESTIVAL "Include Festival Voice Synthesis Support" Off \
@@ -47,20 +47,6 @@ OPTIONS= SHAPELIB "Include Shapelib support" On \
.include <bsd.port.pre.mk>
-.if defined(WITH_FESTIVAL)
-RUN_DEPENDS+= festival:${PORTSDIR}/audio/festival
-.else
-CONFIGURE_ARGS+= --without-festival
-.endif
-
-.if defined(WITH_GPSMAN)
-RUN_DEPENDS+= gpsmanshp:${PORTSDIR}/graphics/gpsmanshp
-WITH_SHAPELIB= true
-.undef WITHOUT_SHAPELIB
-.else
-CONFIGURE_ARGS+= --without-gpsman
-.endif
-
.if defined(WITHOUT_SHAPELIB)
CONFIGURE_ARGS+= --without-shapelib
.else
@@ -89,12 +75,30 @@ LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
.endif
+.if defined(WITH_GEOTIFF)
+LIB_DEPENDS+= geotiff:${PORTSDIR}/graphics/libgeotiff
+.endif
+
.if defined(WITH_GDAL)
LIB_DEPENDS+= gdal:${PORTSDIR}/graphics/gdal
.else
CONFIGURE_ARGS+= --without-gdal
.endif
+.if defined(WITH_GPSMAN)
+BUILD_DEPENDS+= ${LOCALBASE}/share/doc/gpsmanshp/GPSManSHP.pdf:${PORTSDIR}/graphics/gpsmanshp
+WITH_SHAPELIB= true
+.undef WITHOUT_SHAPELIB
+.else
+CONFIGURE_ARGS+= --without-gpsman
+.endif
+
+.if defined(WITH_FESTIVAL)
+BUILD_DEPENDS+= festival:${PORTSDIR}/audio/festival
+.else
+CONFIGURE_ARGS+= --without-festival
+.endif
+
.if defined(WITH_RTREE)
CONFIGURE_ARGS+= --with-rtree
.endif
@@ -120,7 +124,7 @@ USE_BDB= 43
.endif
.if defined(WITH_DB40) || defined(WITH_DB41) || defined(WITH_DB42) || defined(WITH_DB43)
-CONFIGURE_ARGS+= --with-bdb-incdir=${BDB_INCLUDE_DIR}
+CONFIGURE_ARGS+= --with-bdb-incdir=${BDB_INCLUDE_DIR}
.endif
.if defined(WITH_OPTIMIZED_CFLAGS)
diff --git a/comms/xastir/distinfo b/comms/xastir/distinfo
index 1536416e6f90..787387849c0e 100644
--- a/comms/xastir/distinfo
+++ b/comms/xastir/distinfo
@@ -1,3 +1,3 @@
-MD5 (xastir-1.8.2.tar.gz) = 77b2c60cd59de17c2caccb13f95d4993
-SHA256 (xastir-1.8.2.tar.gz) = 6530851830801a331ea5fb874e3e00211994b7b6754f6396b38f6d3d649478d7
-SIZE (xastir-1.8.2.tar.gz) = 1642849
+MD5 (xastir-1.8.4.tar.gz) = 10fcf7a63b0696ab6fefc40f1a80fd1d
+SHA256 (xastir-1.8.4.tar.gz) = 2c020dd4bbea8d8b6f7773ab6b1327f9c8252e4e3dbf384e200b4531a51b80fc
+SIZE (xastir-1.8.4.tar.gz) = 1685220
diff --git a/comms/xastir/files/patch-main.c b/comms/xastir/files/patch-main.c
deleted file mode 100644
index 3bad3bd551de..000000000000
--- a/comms/xastir/files/patch-main.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/main.c~ Sun Jul 9 16:46:31 2006
-+++ src/main.c Sun Jul 9 18:04:42 2006
-@@ -10284,7 +10284,7 @@
- // acceptable at 200.
- nexttime = 200;
- #else
-- nexttime = 2;
-+ nexttime = 10;
- #endif // __CYGWIN__
-
-