aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
Diffstat (limited to 'comms')
-rw-r--r--comms/usbmuxd/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/comms/usbmuxd/Makefile b/comms/usbmuxd/Makefile
index 5d8278cd3049..a7515d560136 100644
--- a/comms/usbmuxd/Makefile
+++ b/comms/usbmuxd/Makefile
@@ -23,8 +23,17 @@ PORTDOCS= AUTHORS README README.devel
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800069
-BROKEN= requires libusb 1.0
+.if ${OSVERSION} == 800107 || ${OSVERSION} == 900002
+HAVE_LIBUSB104!= ${GREP} --quiet "libusb_fill_bulk_transfer" \
+ /usr/include/libusb.h \
+ && ${ECHO} yes || ${ECHO} no
+.elif ${OSVERSION} > 800107 && ${OSVERSION} < 900000 || ${OSVERSION} > 900002
+HAVE_LIBUSB104= yes
+.else
+HAVE_LIBUSB104= no
+.endif
+.if ${HAVE_LIBUSB104} == "no"
+BROKEN= requires libusb 1.0.4
.endif
pre-configure: