aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/klog/Makefile24
-rw-r--r--comms/klog/distinfo2
-rw-r--r--comms/klog/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index a6e5255af040..7863565d03bf 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -74,6 +74,7 @@
SUBDIR += jsdr
SUBDIR += kb
SUBDIR += kermit
+ SUBDIR += klog
SUBDIR += kremotecontrol
SUBDIR += libconcord
SUBDIR += libfec
diff --git a/comms/klog/Makefile b/comms/klog/Makefile
new file mode 100644
index 000000000000..fb3b54a57c5f
--- /dev/null
+++ b/comms/klog/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= klog
+PORTVERSION= 0.9.0.2
+CATEGORIES= comms hamradio
+MASTER_SITES= SAVANNAH
+
+MAINTAINER= hamradio@freebsd.org
+COMMENT= Simple Qt-based amateur radio logger
+
+USES= qmake
+USE_QT4= gui network sql corelib linguist moc_build
+DESKTOP_ENTRIES= "KLog" "Simple Amateur Radio Logging Program" \
+ "" "klog" "Network;HamRadio;" \
+ true
+
+PLIST_FILES= bin/klog \
+ man/man1/klog.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/klog ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/klog.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/comms/klog/distinfo b/comms/klog/distinfo
new file mode 100644
index 000000000000..09f58b2056a0
--- /dev/null
+++ b/comms/klog/distinfo
@@ -0,0 +1,2 @@
+SHA256 (klog-0.9.0.2.tar.gz) = 3ab1d50d8f0b349cc3017de93e5c9bbb43aa0c7abeff703b610b5054537f1339
+SIZE (klog-0.9.0.2.tar.gz) = 234639
diff --git a/comms/klog/pkg-descr b/comms/klog/pkg-descr
new file mode 100644
index 000000000000..df01b09c0a73
--- /dev/null
+++ b/comms/klog/pkg-descr
@@ -0,0 +1,6 @@
+KLog is a simple amateur radio logging program for KDE
+
+It supports QSL management, DXCC, WAZ and local awards, DX Clusters,
+Basic IOTA, Satellite support, and import from ADIF, TLF, and Cabrillo formats.
+
+WWW: http://jaime.robles.es/klog/