aboutsummaryrefslogtreecommitdiffstats
path: root/converters/lua-json/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/lua-json/Makefile')
-rw-r--r--converters/lua-json/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/converters/lua-json/Makefile b/converters/lua-json/Makefile
new file mode 100644
index 000000000000..3591870fc955
--- /dev/null
+++ b/converters/lua-json/Makefile
@@ -0,0 +1,21 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= json
+PORTVERSION= 1.3.3
+CATEGORIES= converters
+PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= JSON parser/creator for Lua
+
+RUN_DEPENDS= ${LUA_PKGNAMEPREFIX}lpeg>=0.8.1:${PORTSDIR}/devel/lua-lpeg
+
+MAKE_ARGS= INSTALL_CMOD=${LUA_MODLIBDIR} INSTALL_LMOD=${LUA_MODSHAREDIR}
+USES= lua:run
+
+GH_ACCOUNT= harningt
+GH_PROJECT= lua${PORTNAME}
+USE_GITHUB= yes
+
+.include <bsd.port.mk>