aboutsummaryrefslogtreecommitdiffstats
path: root/converters/mimepp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/mimepp/Makefile')
-rw-r--r--converters/mimepp/Makefile36
1 files changed, 16 insertions, 20 deletions
diff --git a/converters/mimepp/Makefile b/converters/mimepp/Makefile
index 6e02c0e9c8aa..af699abd4d31 100644
--- a/converters/mimepp/Makefile
+++ b/converters/mimepp/Makefile
@@ -6,31 +6,27 @@
#
PORTNAME= mimepp
-PORTVERSION= 1.0
+PORTVERSION= 1.2.4
CATEGORIES= converters
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= devel/lang/c++
+MASTER_SITES= http://www.hunnysoft.com/mimepp/
MAINTAINER= ports@FreeBSD.org
-MAKEFILE= makefile.unx
-ALL_TARGET= lib
+MAKEFILE= makefile-unix
+ALL_TARGET= default
do-install:
- @ ${INSTALL_DATA} ${WRKSRC}/libmimepp.a ${PREFIX}/lib
- @ ${MKDIR} ${PREFIX}/include/mimepp
-.for file in address.h addrlist.h binhex.h body.h bodypart.h boyermor.h config.h datetime.h debug.h disptype.h entity.h enum.h field.h fieldbdy.h group.h headers.h mailbox.h mboxlist.h mechansm.h mediatyp.h message.h mimepp.h msgcmp.h msgid.h nntp.h param.h pop.h protocol.h smtp.h string.h text.h token.h utility.h uuencode.h
- @ ${INSTALL_DATA} ${WRKSRC}/mimepp/${file} ${PREFIX}/include/mimepp
-.endfor
- @ ${MKDIR} ${PREFIX}/share/doc/mimepp
-.for file in CPYRIGHT LICENSE README Tutorial
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/mimepp
-.endfor
- @ ${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/mimepp
- @ ${MKDIR} ${PREFIX}/share/examples/mimepp
- @ ${INSTALL_DATA} ${FILESDIR}/Makefile ${PREFIX}/share/examples/mimepp
-.for file in attach.cpp attach.h basicmsg.cpp basicmsg.h exampl01.cpp exampl01.txt exampl02.cpp exampl02.txt exampl03.cpp exampl03.txt exampl04.cpp exampl04.txt exampl05.cpp exampl05.txt multipar.cpp multipar.h
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/examples/mimepp
-.endfor
+ ${INSTALL_DATA} ${WRKSRC}/dev/*.a ${PREFIX}/lib
+ @${MKDIR} ${PREFIX}/include/mimepp
+ ${INSTALL_DATA} ${WRKSRC}/src/mimepp/*.h ${PREFIX}/include/mimepp
+ @${MKDIR} ${PREFIX}/share/examples/mimepp
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.cpp ${PREFIX}/share/examples/mimepp
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.h ${PREFIX}/share/examples/mimepp
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.txt ${PREFIX}/share/examples/mimepp
+ ${INSTALL_DATA} ${WRKSRC}/examples/makefile-unix ${PREFIX}/share/examples/mimepp
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/mimepp
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/mimepp
+.endif
.include <bsd.port.mk>