aboutsummaryrefslogtreecommitdiffstats
path: root/converters/py-rencode/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/py-rencode/Makefile')
-rw-r--r--converters/py-rencode/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/converters/py-rencode/Makefile b/converters/py-rencode/Makefile
index 2c9a058c7627..c06747201d83 100644
--- a/converters/py-rencode/Makefile
+++ b/converters/py-rencode/Makefile
@@ -2,12 +2,13 @@
PORTNAME= rencode
PORTVERSION= 1.0.6
+PORTREVISION= 1
CATEGORIES= converters devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= python@FreeBSD.org
-COMMENT= R-encoding and r-decoding implementation
+COMMENT= Web safe object pickling/unpickling
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -17,7 +18,15 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist distutils
+# Make setup.py test target work with setup.py:test_suite
+# See: files/patch-setup.py
+post-patch:
+ ${TOUCH} ${WRKSRC}/tests/__init__.py
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/rencode/_rencode.so
+do-test:
+ cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
.include <bsd.port.mk>