aboutsummaryrefslogtreecommitdiffstats
path: root/converters/rcctools
diff options
context:
space:
mode:
Diffstat (limited to 'converters/rcctools')
-rw-r--r--converters/rcctools/Makefile27
-rw-r--r--converters/rcctools/distinfo3
-rw-r--r--converters/rcctools/pkg-descr9
3 files changed, 39 insertions, 0 deletions
diff --git a/converters/rcctools/Makefile b/converters/rcctools/Makefile
new file mode 100644
index 000000000000..96962ed745e1
--- /dev/null
+++ b/converters/rcctools/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: rcctools
+# Date created: 20-08-2009
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rcctools
+PORTVERSION= 0.1.1
+CATEGORIES= converters
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= rusxmms
+
+MAINTAINER= admin@lissyara.su
+COMMENT= Charset conversion utility with language and encoding autodetection
+
+LIB_DEPENDS= rcc.2:${PORTSDIR}/devel/librcc
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= bin/rcc-recode
+
+.include <bsd.port.mk>
diff --git a/converters/rcctools/distinfo b/converters/rcctools/distinfo
new file mode 100644
index 000000000000..8958ff67ed15
--- /dev/null
+++ b/converters/rcctools/distinfo
@@ -0,0 +1,3 @@
+MD5 (rcctools-0.1.1.tar.bz2) = 7ca30f2b38aacebc4a8943a1894a50aa
+SHA256 (rcctools-0.1.1.tar.bz2) = 4d9d9c15a5144dde524ed03157cd39160290a09cb3db51c66fc5fcd442177dc6
+SIZE (rcctools-0.1.1.tar.bz2) = 244443
diff --git a/converters/rcctools/pkg-descr b/converters/rcctools/pkg-descr
new file mode 100644
index 000000000000..b3a15bb763aa
--- /dev/null
+++ b/converters/rcctools/pkg-descr
@@ -0,0 +1,9 @@
+Command line interface to devel/librcc library. It is a highly
+configurable tool (supports almost all library functionality) which
+allows to recode standard input on the per-line basis. Additionally,
+there is a special mode providing a way to bring the names of all
+files in the specified directory to appropriate form (to the specified
+encoding, transliterate all names to english, translate all names
+to english, etc.)
+
+WWW: http://rusxmms.sourceforge.net