aboutsummaryrefslogtreecommitdiffstats
path: root/converters/recode/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/recode/Makefile')
-rw-r--r--converters/recode/Makefile38
1 files changed, 30 insertions, 8 deletions
diff --git a/converters/recode/Makefile b/converters/recode/Makefile
index b67477031655..158e37a9ec4e 100644
--- a/converters/recode/Makefile
+++ b/converters/recode/Makefile
@@ -6,25 +6,47 @@
#
PORTNAME= recode
-PORTVERSION= 3.5
-PORTREVISION= 1
+PORTVERSION= 3.6
CATEGORIES= converters
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= recode
-MAINTAINER= torstenb@FreeBSD.org
+MAINTAINER= demon@FreeBSD.org
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
+ LDFLAGS=-L${LOCALBASE}/lib \
+ LIBS=-lintl
MAN1= recode.1
-pre-patch:
- @${CP} ${FILESDIR}/ru.po ${WRKSRC}/po/
- @${PERL} -pi -e 's|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+post-extract: copy-po-files remove-info-files
+
+copy-po-files:
+ @${CP} ${FILESDIR}/ru.po ${WRKSRC}/i18n
+
+remove-info-files:
+ @${RM} -f ${WRKSRC}/doc/${PORTNAME}.info*
+
+post-patch: patch-po-files patch-configure patch-makeinfo
+
+patch-po-files:
+ @${PERL} -pi -e '\
+ if (/Project-Id-Version/) { \
+ s/3\.[45](r|\.[0-9])?/3.6/; \
+ s/: (Free )?recode/: GNU recode/; \
+ } \
+ ' ${WRKSRC}/i18n/*.po
+
+patch-configure:
+ @${PERL} -pi -e 's|DATADIRNAME=lib|DATADIRNAME=share|g' \
+ ${WRKSRC}/configure
+
+patch-makeinfo:
+ @${PERL} -pi.fbsd -e 's|\@MAKEINFO\@|\@MAKEINFO\@ --no-split|g' \
+ ${WRKSRC}/doc/Makefile.in
.include <bsd.port.mk>