aboutsummaryrefslogtreecommitdiffstats
path: root/converters/ruby-bsdconv/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/ruby-bsdconv/Makefile')
-rw-r--r--converters/ruby-bsdconv/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/converters/ruby-bsdconv/Makefile b/converters/ruby-bsdconv/Makefile
new file mode 100644
index 000000000000..ddcd56fa413b
--- /dev/null
+++ b/converters/ruby-bsdconv/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: ruby-bsdconv
+# Date created: 13 Oct 2011
+# Whom: buganini@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsdconv
+PORTVERSION= 1.2
+CATEGORIES= converters ruby
+MASTER_SITES= https://github.com/buganini/ruby-${PORTNAME}/tarball/${PORTVERSION}/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= buganini-${PORTNAME}-${PORTVERSION}-0-g${GITVERSION}
+
+MAINTAINER= buganini@gmail.com
+COMMENT= Ruby wrapper for bsdconv
+
+LICENSE= BSD
+
+LIB_DEPENDS= bsdconv.6:${PORTSDIR}/converters/bsdconv
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+GITVERSION= cc3a4f4
+FETCH_ARGS= -pRr
+WRKSRC= ${WRKDIR}/buganini-ruby-${PORTNAME}-${GITVERSION}
+
+.include <bsd.port.mk>