aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/py-rencode/Makefile19
-rw-r--r--converters/py-rencode/distinfo2
-rw-r--r--converters/py-rencode/pkg-descr10
4 files changed, 32 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 51fe59760a46..45acee3d6b73 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -141,6 +141,7 @@
SUBDIR += py-bsdconv
SUBDIR += py-iconv
SUBDIR += py-pisa
+ SUBDIR += py-rencode
SUBDIR += py-unidecode
SUBDIR += py-zfec
SUBDIR += rcctools
diff --git a/converters/py-rencode/Makefile b/converters/py-rencode/Makefile
new file mode 100644
index 000000000000..f06d0bdbf14f
--- /dev/null
+++ b/converters/py-rencode/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= rencode
+PORTVERSION= 1.0.3
+CATEGORIES= converters devel python
+MASTER_SITES= https://www.xpra.org/src/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= R-encoding and r-decoding implementation
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= cython:${PORTSDIR}/lang/cython
+
+USE_PYTHON= autoplist distutils
+USES= python tar:xz
+
+.include <bsd.port.mk>
diff --git a/converters/py-rencode/distinfo b/converters/py-rencode/distinfo
new file mode 100644
index 000000000000..37d95cb0a917
--- /dev/null
+++ b/converters/py-rencode/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rencode-1.0.3.tar.xz) = f0e48d55b5fd6c5998416fa4220d51f91008aef72560ec351dd35b3872d0b9a9
+SIZE (rencode-1.0.3.tar.xz) = 21184
diff --git a/converters/py-rencode/pkg-descr b/converters/py-rencode/pkg-descr
new file mode 100644
index 000000000000..e46490615537
--- /dev/null
+++ b/converters/py-rencode/pkg-descr
@@ -0,0 +1,10 @@
+The rencode module is similar to bencode from the BitTorrent project.
+For complex, heterogeneous data structures with many small elements,
+r-encodings take up significantly less space than b-encodings.
+
+This version of rencode is a complete rewrite in Cython to attempt to
+increase the performance over the pure Python module written by Petru
+Paler, Connelly Barnes et al. Later, it was forked, enhanced, and
+bundled with Deluge. Now, it is re-packaged and distributed by Xpra.
+
+WWW: https://github.com/aresch/rencode