aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
Diffstat (limited to 'converters')
-rw-r--r--converters/libb64/Makefile23
1 files changed, 9 insertions, 14 deletions
diff --git a/converters/libb64/Makefile b/converters/libb64/Makefile
index d83e27456456..451cdba61142 100644
--- a/converters/libb64/Makefile
+++ b/converters/libb64/Makefile
@@ -6,26 +6,21 @@ PORTVERSION= 1.2
CATEGORIES= converters mail
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+EXTRACT_SUFX= .zip
MAINTAINER= ismail.yenigul@surgate.com
-COMMENT= A library of ANSI C routines for fast encoding/decoding data
+COMMENT= Library of ANSI C routines for fast encoding/decoding data
BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
+USES= gmake
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_ZIP= yes
-USE_GMAKE= yes
-NO_STAGE= yes
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/src/libb64.a ${PREFIX}/lib
- ${MKDIR} ${PREFIX}/include/b64
- ${INSTALL_DATA} ${WRKSRC}/include/b64/*.h ${PREFIX}/include/b64
-
-.include <bsd.port.pre.mk>
+BROKEN_powerpc= Does not compile on powerpc
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
-.endif
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/libb64.a ${STAGEDIR}${PREFIX}/lib
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/b64
+ ${INSTALL_DATA} ${WRKSRC}/include/b64/*.h ${STAGEDIR}${PREFIX}/include/b64
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>