aboutsummaryrefslogtreecommitdiffstats
path: root/databases/cego/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/cego/Makefile')
-rw-r--r--databases/cego/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/databases/cego/Makefile b/databases/cego/Makefile
index 4d2b8f069a9f..6ba0a169e1d8 100644
--- a/databases/cego/Makefile
+++ b/databases/cego/Makefile
@@ -2,6 +2,7 @@
PORTNAME= cego
PORTVERSION= 2.32.6
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://www.lemke-it.com/
@@ -13,15 +14,16 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= liblfcbase.so:devel/lfcbase \
liblfcxml.so:devel/lfcxml
-RUN_DEPENDS= ${LOCALBASE}/bin/sudo:security/sudo
+RUN_DEPENDS= ${LOCALBASE}/bin/sudo:security/sudo \
+ bash:shells/bash
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
+TEST_TARGET= check
USE_LDCONFIG= yes
-USES= libtool ncurses readline shebangfix
-SHEBANG_FILES= tools/cgbackup tools/cgrecover
+USES= libtool localbase ncurses readline shebangfix
+SHEBANG_FILES= tools/cgbackup tools/cgrecover tools/cgsimload
USERS= cego
GROUPS= cego
@@ -44,7 +46,4 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcego.so.2.0.0
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcgwrap.so.2.0.0
-do-test:
- cd ${WRKSRC} && ${MAKE} check
-
.include <bsd.port.mk>