aboutsummaryrefslogtreecommitdiffstats
path: root/databases/gnomedb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/gnomedb/Makefile')
-rw-r--r--databases/gnomedb/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/databases/gnomedb/Makefile b/databases/gnomedb/Makefile
index f0a1ace2ae14..64f633ab3621 100644
--- a/databases/gnomedb/Makefile
+++ b/databases/gnomedb/Makefile
@@ -16,27 +16,20 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gda-client.0:${PORTSDIR}/databases/libgda
-
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gnomehier libgda
USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-pthread -L${LOCALBASE}/lib -lintl"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(GNOME_datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
- s|\$\(GNOME_datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>