aboutsummaryrefslogtreecommitdiffstats
path: root/databases/libgda3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/libgda3/Makefile')
-rw-r--r--databases/libgda3/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/databases/libgda3/Makefile b/databases/libgda3/Makefile
index e63377a45006..d5655f589dee 100644
--- a/databases/libgda3/Makefile
+++ b/databases/libgda3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libgda
PORTVERSION= 0.2.10
+PORTREVISION= 1
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-db
@@ -18,12 +19,15 @@ LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv \
USE_GNOMECTRL= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl -lgdbm"
+MAN3= Gnome::GDA::Client.3 Gnome::GDA::Common.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure