aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mongodb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mongodb/Makefile')
-rw-r--r--databases/mongodb/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index 9c2666dd464f..50c8f66435a1 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -14,8 +14,7 @@ COMMENT= NOSQL distributed document-oriented database
LICENSE= AGPLv3 APACHE20
LICENSE_COMB= multi
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
- libpcre.so:${PORTSDIR}/devel/pcre \
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
libsnappy.so:${PORTSDIR}/archivers/snappy \
libv8.so:${PORTSDIR}/lang/v8 \
# boost 1.52/1.55 from ports make mongod segfaulting with many tests
@@ -32,7 +31,7 @@ OPTIONS_DEFINE= SSL SASL TEST
OPTIONS_DEFAULT=SSL
TEST_DESC= Add support for running regression test
-USES= scons
+USES= execinfo scons
MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} --cc=${CC} --cxx=${CXX} \
--use-system-pcre --use-system-snappy --use-system-v8