aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBD-Google/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBD-Google/Makefile')
-rw-r--r--databases/p5-DBD-Google/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/databases/p5-DBD-Google/Makefile b/databases/p5-DBD-Google/Makefile
new file mode 100644
index 000000000000..e475335292b5
--- /dev/null
+++ b/databases/p5-DBD-Google/Makefile
@@ -0,0 +1,39 @@
+# ex:ts=8
+# Ports collection makefile for: p5-DBD-Google
+# Date created: Apr 7, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBD-Google
+PORTVERSION= 0.11
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Treat Google as a datasource for DBI
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/Google.pm:${PORTSDIR}/net/p5-Net-Google \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/SQL/Parser.pm:${PORTSDIR}/databases/p5-SQL-Statement
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBD::Google.3 SQL::Dialects::Google.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>