aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBD-InterBase/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBD-InterBase/Makefile')
-rw-r--r--databases/p5-DBD-InterBase/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/databases/p5-DBD-InterBase/Makefile b/databases/p5-DBD-InterBase/Makefile
new file mode 100644
index 000000000000..fcf66610fee3
--- /dev/null
+++ b/databases/p5-DBD-InterBase/Makefile
@@ -0,0 +1,26 @@
+# Created by: Sergey Skvortsov <skv@protey.ru>
+# $FreeBSD$
+
+PORTNAME= DBD-InterBase
+PORTVERSION= 0.48
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= DBD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= yuri@rivera.ru
+COMMENT= DBI driver for InterBase/Firebird/Yaffil RDBMS server
+
+BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_FIREBIRD= yes
+
+USES= perl5
+USE_PERL5= patch configure
+
+post-patch:
+ @${PERL} -pi -e 's,%%IB_BASE%%,${LOCALBASE},g' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>