aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBD-SQLite2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBD-SQLite2/Makefile')
-rw-r--r--databases/p5-DBD-SQLite2/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/databases/p5-DBD-SQLite2/Makefile b/databases/p5-DBD-SQLite2/Makefile
index d2a3c236704e..237cc38861f9 100644
--- a/databases/p5-DBD-SQLite2/Makefile
+++ b/databases/p5-DBD-SQLite2/Makefile
@@ -15,12 +15,19 @@ PKGNAMEPREFIX= p5-
MAINTAINER= nork@FreeBSD.org
COMMENT= Provides access to SQLite2 databases through the DBI
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBD::SQLite.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>