aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBIx-Class-EncodedColumn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBIx-Class-EncodedColumn/Makefile')
-rw-r--r--databases/p5-DBIx-Class-EncodedColumn/Makefile44
1 files changed, 18 insertions, 26 deletions
diff --git a/databases/p5-DBIx-Class-EncodedColumn/Makefile b/databases/p5-DBIx-Class-EncodedColumn/Makefile
index 6c86d0d0bcab..4116925c7498 100644
--- a/databases/p5-DBIx-Class-EncodedColumn/Makefile
+++ b/databases/p5-DBIx-Class-EncodedColumn/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= DBIx-Class-EncodedColumn
-PORTVERSION= 0.00012
+PORTVERSION= 0.00013
CATEGORIES= databases perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,34 +14,26 @@ LICENSE= ART10 GPLv1
LICENSE_COMB= dual
BUILD_DEPENDS= p5-DBIx-Class>=0.06002:${PORTSDIR}/databases/p5-DBIx-Class \
- p5-Sub-Name>=0.04:${PORTSDIR}/devel/p5-Sub-Name \
- p5-SQL-Translator>=0.09.003:${PORTSDIR}/databases/p5-SQL-Translator
+ p5-SQL-Translator>=0.09.003:${PORTSDIR}/databases/p5-SQL-Translator \
+ p5-Sub-Name>=0.04:${PORTSDIR}/devel/p5-Sub-Name
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
- p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
- p5-Dir-Self>=0:${PORTSDIR}/devel/p5-Dir-Self
+TEST_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-Dir-Self>=0:${PORTSDIR}/devel/p5-Dir-Self \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
USES= perl5
-USE_PERL5= configure extract
+USE_PERL5= configure
-post-extract:
- @${PERL} -i -ne 'print unless m,^build_requires, || m,^feature, .. m,;,' ${WRKSRC}/Makefile.PL
+OPTIONS_DEFINE= BLOWFISH OPENPGP
+OPTIONS_DEFAULT=BLOWFISH OPENPGP
+BLOWFISH_DESC= Blowfish support
+OPENPGP_DESC= Crypt::OpenPGP (gpg) support
-OPTIONS_DEFINE= SHA BLOWFISH OPENPGP
-OPTIONS_DEFAULT= SHA BLOWFISH OPENPGP
-SHA_DESC= Digest::SHA Support
-BLOWFISH_DESC= Blowfish Support
-OPENPGP_DESC= Crypt::OpenPGP (gpg) Support
+BLOWFISH_BUILD_DEPENDS= p5-Crypt-Eksblowfish>=0:${PORTSDIR}/security/p5-Crypt-Eksblowfish
+BLOWFISH_RUN_DEPENDS= p5-Crypt-Eksblowfish>=0:${PORTSDIR}/security/p5-Crypt-Eksblowfish
+OPENPGP_BUILD_DEPENDS= p5-Crypt-CAST5_PP>=0:${PORTSDIR}/security/p5-Crypt-CAST5_PP \
+ p5-Crypt-OpenPGP>=0:${PORTSDIR}/security/p5-Crypt-OpenPGP
+OPENPGP_RUN_DEPENDS= p5-Crypt-CAST5_PP>=0:${PORTSDIR}/security/p5-Crypt-CAST5_PP \
+ p5-Crypt-OpenPGP>=0:${PORTSDIR}/security/p5-Crypt-OpenPGP
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MBLOWFISH}
-RUN_DEPENDS+= p5-Crypt-Eksblowfish>=0:${PORTSDIR}/security/p5-Crypt-Eksblowfish
-.endif
-
-.if ${PORT_OPTIONS:MOPENPGP}
-RUN_DEPENDS+= p5-Crypt-OpenPGP>=0:${PORTSDIR}/security/p5-Crypt-OpenPGP \
- p5-Crypt-CAST5_PP>=0:${PORTSDIR}/security/p5-Crypt-CAST5_PP
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>