aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBIx-DBSchema/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBIx-DBSchema/Makefile')
-rw-r--r--databases/p5-DBIx-DBSchema/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/databases/p5-DBIx-DBSchema/Makefile b/databases/p5-DBIx-DBSchema/Makefile
index 65671aab0e3d..93c5c50b5365 100644
--- a/databases/p5-DBIx-DBSchema/Makefile
+++ b/databases/p5-DBIx-DBSchema/Makefile
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= An OO-interface to database schemas
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -28,4 +27,14 @@ MAN3= DBIx::DBSchema.3 DBIx::DBSchema::ColGroup.3 \
DBIx::DBSchema::DBD::mysql.3 DBIx::DBSchema::DBD::Pg.3 \
DBIx::DBSchema::DBD::Sybase.3 DBIx::DBSchema::Table.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>