aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-ResourcePool-Resource-DBI/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-ResourcePool-Resource-DBI/Makefile')
-rw-r--r--databases/p5-ResourcePool-Resource-DBI/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/databases/p5-ResourcePool-Resource-DBI/Makefile b/databases/p5-ResourcePool-Resource-DBI/Makefile
index c06b68416b77..aef6635ca359 100644
--- a/databases/p5-ResourcePool-Resource-DBI/Makefile
+++ b/databases/p5-ResourcePool-Resource-DBI/Makefile
@@ -16,8 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@FreeBSD.org
COMMENT= ResourcePool::Resource::DBI - A ResourcePool wrapper for DBI
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/ResourcePool.pm:${PORTSDIR}/devel/p5-ResourcePool \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/ResourcePool.pm:${PORTSDIR}/devel/p5-ResourcePool
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -27,4 +26,14 @@ MAN3= ResourcePool::Resource::DBI.3 ResourcePool::Factory::DBI.3 \
ResourcePool::Command::DBI::Execute.3 ResourcePool::Command::DBI::Select.3 \
ResourcePool::Command::DBI::SelectRow.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>