aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-sqlrelay/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-sqlrelay/Makefile')
-rw-r--r--databases/p5-sqlrelay/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/databases/p5-sqlrelay/Makefile b/databases/p5-sqlrelay/Makefile
index 939cbad866e6..02bdcee42f7b 100644
--- a/databases/p5-sqlrelay/Makefile
+++ b/databases/p5-sqlrelay/Makefile
@@ -16,9 +16,7 @@ MAINTAINER= knu@FreeBSD.org
COMMENT= Perl5 modules to access to SQL Relay, including a DBD interface
EXTRACT_DEPENDS= ${NONEXISTENT}:${SQLRELAY_PORTDIR}:patch
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
LIB_DEPENDS= sqlrclient.0:${SQLRELAY_PORTDIR}
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
USE_PERL5= yes
@@ -55,4 +53,14 @@ do-install:
${MAKE_ARGS} ${INSTALL_TARGET}; \
done
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>