aboutsummaryrefslogtreecommitdiffstats
path: root/databases/pgbouncer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/pgbouncer/Makefile')
-rw-r--r--databases/pgbouncer/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/databases/pgbouncer/Makefile b/databases/pgbouncer/Makefile
index c71bdb96f558..7bea6b3ed48f 100644
--- a/databases/pgbouncer/Makefile
+++ b/databases/pgbouncer/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= pgbouncer
-PORTVERSION= 1.0.8
-PORTREVISION= 1
+PORTVERSION= 1.1.2
CATEGORIES= databases
-MASTER_SITES= http://pgfoundry.org/frs/download.php/1399/
+MASTER_SITES= http://pgfoundry.org/frs/download.php/1532/
MAINTAINER= skv@FreeBSD.org
COMMENT= Lightweight connection pooler for PostgreSQL
@@ -22,10 +21,19 @@ SUB_FILES= pkg-message
GNU_CONFIGURE= yes
USE_GMAKE= yes
+.if ! defined(NO_INSTALL_MANPAGES)
+MAN1= pgbouncer.1
+MAN5= pgbouncer.5
+.endif
+
CONFIGURE_ARGS= --with-libevent=${LOCALBASE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pgbouncer ${PREFIX}/bin/
+.if ! defined(NO_INSTALL_MANPAGES)
+ ${INSTALL_MAN} ${WRKSRC}/doc/pgbouncer.1 ${PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/doc/pgbouncer.5 ${PREFIX}/man/man5/
+.endif
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/etc/pgbouncer.ini ${EXAMPLESDIR}
@${CAT} ${PKGMESSAGE}