aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql90-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql90-server/Makefile')
-rw-r--r--databases/postgresql90-server/Makefile148
1 files changed, 87 insertions, 61 deletions
diff --git a/databases/postgresql90-server/Makefile b/databases/postgresql90-server/Makefile
index 7ce9dab829cd..80d9c75a968c 100644
--- a/databases/postgresql90-server/Makefile
+++ b/databases/postgresql90-server/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME?= postgresql
-DISTVERSION?= 8.4.3
-PORTREVISION?= 2
+DISTVERSION?= 9.0.0
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= source/v${DISTVERSION}
@@ -16,15 +15,13 @@ PKGNAMESUFFIX?= -server
MAINTAINER?= girgen@FreeBSD.org
COMMENT?= The most advanced open-source database available anywhere
-CONFLICTS?= ${PORTNAME}-client-7.* \
- ${PORTNAME}${PKGNAMESUFFIX}-7.* \
- ${PORTNAME}-client-8.[0-35-9]* \
- ${PORTNAME}${PKGNAMESUFFIX}-8.[0-35-9]*
+CONFLICTS?= ${PORTNAME}-client-[78]* \
+ ${PORTNAME}${PKGNAMESUFFIX}-[78]*
WRKSRC= ${WRKDIR}/postgresql-${DISTVERSION}
DIST_SUBDIR= postgresql
-UNIQUENAME?= ${PORTNAME}84
+UNIQUENAME?= ${PORTNAME}90
LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}${PKGNAMESUFFIX}
PKGINSTALL?= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
@@ -83,6 +80,7 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
+OPTIONS+= DTRACE "Build with DTrace probes (server only)" off
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= LDAP "Build with LDAP authentication support" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
@@ -108,10 +106,9 @@ IGNORE= options WITH_ICU and WITH_ICU4 are mutually exclusive
USE_AUTOTOOLS= autoconf:267
CONFIGURE_ARGS+=--with-icu
PATCH_SITES+= http://people.freebsd.org/~girgen/postgresql-icu/:icu
-PATCHFILES+= pg-840-icu-2009-09-15.diff.gz:icu
+PATCHFILES+= pg-900-icu-2010-09-19.diff.gz:icu
. if defined(WITH_ICU4)
-LIB_DEPENDS+= icudata.43:${PORTSDIR}/devel/icu4
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-icu4
+LIB_DEPENDS+= icudata.44:${PORTSDIR}/devel/icu4
. else
LIB_DEPENDS+= icudata.38:${PORTSDIR}/devel/icu
. endif
@@ -119,6 +116,11 @@ LIB_DEPENDS+= icudata.38:${PORTSDIR}/devel/icu
PATCH_DIST_STRIP=-p1
+. if defined(SERVER_ONLY) && defined(WITH_DTRACE)
+CONFIGURE_ARGS+=--enable-dtrace
+LDFLAGS+=-lelf
+. endif
+
. if defined(SERVER_ONLY) && defined(WITH_PAM)
CONFIGURE_ARGS+=--with-pam
. endif
@@ -199,57 +201,81 @@ MAN1= clusterdb.1 createdb.1 createlang.1 createuser.1 \
pg_dump.1 pg_dumpall.1 pg_resetxlog.1 pg_restore.1 \
postgres.1 postmaster.1 psql.1 reindexdb.1 vacuumdb.1
-MAN7= abort.7 alter_aggregate.7 alter_conversion.7 alter_database.7 \
- alter_domain.7 alter_foreign_data_wrapper.7 alter_function.7 alter_group.7 alter_server.7 \
- alter_user_mapping.7 alter_index.7 alter_language.7 alter_operator_class.7 \
- alter_operator_family.7 \
- alter_role.7 \
- alter_schema.7 alter_sequence.7 alter_table.7 \
- alter_text_search_configuration.7 \
- alter_text_search_dictionary.7 \
- alter_text_search_parser.7 \
- alter_text_search_template.7 \
- alter_trigger.7 alter_user.7 alter_view.7 analyze.7 begin.7 \
- checkpoint.7 close.7 cluster.7 comment.7 commit.7 \
- commit_prepared.7 \
- copy.7 create_aggregate.7 create_cast.7 \
- create_constraint_trigger.7 create_conversion.7 \
- create_database.7 create_domain.7 create_foreign_data_wrapper.7 \
- create_function.7 \
- create_group.7 create_index.7 create_language.7 \
- create_operator.7 create_operator_class.7 \
- create_operator_family.7 create_role.7 \
- create_rule.7 create_schema.7 create_sequence.7 \
- create_server.7 create_table.7 create_table_as.7 \
- create_text_search_configuration.7 \
- create_text_search_dictionary.7 \
- create_text_search_parser.7 \
- create_text_search_template.7 create_trigger.7 \
- create_type.7 create_user.7 create_user_mapping.7 create_view.7 deallocate.7 \
- declare.7 delete.7 discard.7 \
- drop_aggregate.7 drop_cast.7 drop_conversion.7 \
- drop_database.7 drop_domain.7 drop_foreign_data_wrapper.7 drop_function.7 \
- drop_group.7 drop_index.7 drop_language.7 \
- drop_operator.7 drop_operator_class.7 drop_operator_family.7 \
- drop_owned.7 drop_role.7 drop_rule.7 \
- drop_schema.7 drop_sequence.7 drop_server.7 drop_table.7 \
- drop_text_search_configuration.7 \
- drop_text_search_dictionary.7 \
- drop_text_search_parser.7 \
- drop_text_search_template.7 drop_trigger.7 \
- drop_type.7 drop_user.7 drop_user_mapping.7 drop_view.7 end.7 execute.7 \
- explain.7 fetch.7 grant.7 insert.7 listen.7 load.7 \
- lock.7 move.7 notify.7 prepare.7 prepare_transaction.7 \
- reassign_owned.7 reindex.7 reset.7 \
- revoke.7 rollback.7 rollback_prepared.7 select.7 \
- select_into.7 set.7 \
- set_constraints.7 set_role.7 set_transaction.7 show.7 \
- set_session_authorization.7 start_transaction.7 \
- table.7 truncate.7 unlisten.7 update.7 vacuum.7 \
- alter_operator.7 alter_tablespace.7 alter_type.7 \
- create_tablespace.7 drop_tablespace.7 \
- release_savepoint.7 rollback_to_savepoint.7 \
- savepoint.7 values.7 with.7
+MAN3= SPI_connect.3 SPI_copytuple.3 SPI_cursor_close.3 SPI_cursor_fetch.3 \
+ SPI_cursor_find.3 SPI_cursor_move.3 SPI_cursor_open.3 \
+ SPI_cursor_open_with_args.3 SPI_cursor_open_with_paramlist.3 \
+ SPI_exec.3 SPI_execp.3 SPI_execute.3 SPI_execute_plan.3 \
+ SPI_execute_plan_with_paramlist.3 SPI_execute_with_args.3 \
+ SPI_finish.3 SPI_fname.3 SPI_fnumber.3 SPI_freeplan.3 \
+ SPI_freetuple.3 SPI_freetuptable.3 SPI_getargcount.3 \
+ SPI_getargtypeid.3 SPI_getbinval.3 SPI_getnspname.3 \
+ SPI_getrelname.3 SPI_gettype.3 SPI_gettypeid.3 \
+ SPI_getvalue.3 SPI_is_cursor_plan.3 SPI_modifytuple.3 \
+ SPI_palloc.3 SPI_pfree.3 SPI_pop.3 SPI_prepare.3 \
+ SPI_prepare_cursor.3 SPI_prepare_params.3 SPI_push.3 \
+ SPI_repalloc.3 SPI_returntuple.3 SPI_saveplan.3 \
+ SPI_scroll_cursor_fetch.3 SPI_scroll_cursor_move.3 \
+ dblink.3 dblink_build_sql_delete.3 dblink_build_sql_insert.3 \
+ dblink_build_sql_update.3 dblink_cancel_query.3 \
+ dblink_close.3 dblink_connect.3 dblink_connect_u.3 \
+ dblink_disconnect.3 dblink_error_message.3 dblink_exec.3 \
+ dblink_fetch.3 dblink_get_connections.3 dblink_get_notify.3 \
+ dblink_get_pkey.3 dblink_get_result.3 dblink_is_busy.3 \
+ dblink_open.3 dblink_send_query.3
+
+MAN7= ABORT.7 ALTER_AGGREGATE.7 ALTER_CONVERSION.7 ALTER_DATABASE.7 \
+ ALTER_DEFAULT_PRIVILEGES.7 \
+ ALTER_DOMAIN.7 ALTER_FOREIGN_DATA_WRAPPER.7 ALTER_FUNCTION.7 ALTER_GROUP.7 \
+ ALTER_LARGE_OBJECT.7 ALTER_SERVER.7 \
+ ALTER_USER_MAPPING.7 ALTER_INDEX.7 ALTER_LANGUAGE.7 ALTER_OPERATOR_CLASS.7 \
+ ALTER_OPERATOR_FAMILY.7 \
+ ALTER_ROLE.7 \
+ ALTER_SCHEMA.7 ALTER_SEQUENCE.7 ALTER_TABLE.7 \
+ ALTER_TEXT_SEARCH_CONFIGURATION.7 \
+ ALTER_TEXT_SEARCH_DICTIONARY.7 \
+ ALTER_TEXT_SEARCH_PARSER.7 \
+ ALTER_TEXT_SEARCH_TEMPLATE.7 \
+ ALTER_TRIGGER.7 ALTER_USER.7 ALTER_VIEW.7 ANALYZE.7 BEGIN.7 \
+ CHECKPOINT.7 CLOSE.7 CLUSTER.7 COMMENT.7 COMMIT.7 \
+ COMMIT_PREPARED.7 \
+ COPY.7 CREATE_AGGREGATE.7 CREATE_CAST.7 \
+ CREATE_CONSTRAINT_TRIGGER.7 CREATE_CONVERSION.7 \
+ CREATE_DATABASE.7 CREATE_DOMAIN.7 CREATE_FOREIGN_DATA_WRAPPER.7 \
+ CREATE_FUNCTION.7 \
+ CREATE_GROUP.7 CREATE_INDEX.7 CREATE_LANGUAGE.7 \
+ CREATE_OPERATOR.7 CREATE_OPERATOR_CLASS.7 \
+ CREATE_OPERATOR_FAMILY.7 CREATE_ROLE.7 \
+ CREATE_RULE.7 CREATE_SCHEMA.7 CREATE_SEQUENCE.7 \
+ CREATE_SERVER.7 CREATE_TABLE.7 CREATE_TABLE_AS.7 \
+ CREATE_TEXT_SEARCH_CONFIGURATION.7 \
+ CREATE_TEXT_SEARCH_DICTIONARY.7 \
+ CREATE_TEXT_SEARCH_PARSER.7 \
+ CREATE_TEXT_SEARCH_TEMPLATE.7 CREATE_TRIGGER.7 \
+ CREATE_TYPE.7 CREATE_USER.7 CREATE_USER_MAPPING.7 CREATE_VIEW.7 DEALLOCATE.7 \
+ DECLARE.7 DELETE.7 DISCARD.7 \
+ DO.7 DROP_AGGREGATE.7 DROP_CAST.7 DROP_CONVERSION.7 \
+ DROP_DATABASE.7 DROP_DOMAIN.7 DROP_FOREIGN_DATA_WRAPPER.7 DROP_FUNCTION.7 \
+ DROP_GROUP.7 DROP_INDEX.7 DROP_LANGUAGE.7 \
+ DROP_OPERATOR.7 DROP_OPERATOR_CLASS.7 DROP_OPERATOR_FAMILY.7 \
+ DROP_OWNED.7 DROP_ROLE.7 DROP_RULE.7 \
+ DROP_SCHEMA.7 DROP_SEQUENCE.7 DROP_SERVER.7 DROP_TABLE.7 \
+ DROP_TEXT_SEARCH_CONFIGURATION.7 \
+ DROP_TEXT_SEARCH_DICTIONARY.7 \
+ DROP_TEXT_SEARCH_PARSER.7 \
+ DROP_TEXT_SEARCH_TEMPLATE.7 DROP_TRIGGER.7 \
+ DROP_TYPE.7 DROP_USER.7 DROP_USER_MAPPING.7 DROP_VIEW.7 END.7 EXECUTE.7 \
+ EXPLAIN.7 FETCH.7 GRANT.7 INSERT.7 LISTEN.7 LOAD.7 \
+ LOCK.7 MOVE.7 NOTIFY.7 PREPARE.7 PREPARE_TRANSACTION.7 \
+ REASSIGN_OWNED.7 REINDEX.7 RESET.7 \
+ REVOKE.7 ROLLBACK.7 ROLLBACK_PREPARED.7 SELECT.7 \
+ SELECT_INTO.7 SET.7 \
+ SET_CONSTRAINTS.7 SET_ROLE.7 SET_TRANSACTION.7 SHOW.7 \
+ SET_SESSION_AUTHORIZATION.7 START_TRANSACTION.7 \
+ TABLE.7 TRUNCATE.7 UNLISTEN.7 UPDATE.7 VACUUM.7 \
+ ALTER_OPERATOR.7 ALTER_TABLESPACE.7 ALTER_TYPE.7 \
+ CREATE_TABLESPACE.7 DROP_TABLESPACE.7 \
+ RELEASE_SAVEPOINT.7 ROLLBACK_TO_SAVEPOINT.7 \
+ SAVEPOINT.7 VALUES.7 WITH.7
.endif
.if defined(SERVER_ONLY)