aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-postgresql/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/py-postgresql/Makefile')
-rw-r--r--databases/py-postgresql/Makefile25
1 files changed, 22 insertions, 3 deletions
diff --git a/databases/py-postgresql/Makefile b/databases/py-postgresql/Makefile
index dee1040f52a5..dfb1c5e3b839 100644
--- a/databases/py-postgresql/Makefile
+++ b/databases/py-postgresql/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postgresql
-PORTVERSION= 1.0.2
+PORTVERSION= 1.0.4
CATEGORIES= databases python
MASTER_SITES= http://python.projects.postgresql.org/files/ \
http://limbo.xim.bz/distfiles/
@@ -17,11 +17,30 @@ DIST_SUBDIR= postgresql
MAINTAINER= c.kworr@gmail.com
COMMENT= Python 3 compatible PostgreSQL database driver and tools
-USE_BZIP2= yes
+USE_XZ= yes
USE_PGSQL= yes
USE_PYTHON= 3.1+
USE_PYDISTUTILS= yes
PYDISTUTILS_EGGINFO= py_${PYDISTUTILS_PKGNAME:C/[^A-Za-z0-9.]+/_/g}-${PYDISTUTILS_PKGVERSION:C/[^A-Za-z0-9.]+/_/g}-${PYTHON_VERSION:S/thon//}.egg-info
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# When Python version is 3.2+ we rewrite all the filenames
+# of TMPPLIST that end with .py[co], so that they conform
+# to PEP 3147 (see http://www.python.org/dev/peps/pep-3147/)
+.if ${PYTHON_REL} >= 320
+PYMAGICTAG= ${PYTHON_CMD} -c 'import imp; print(imp.get_tag())'
+add-plist-post:
+ @${AWK} '\
+ /\.py[co]$$/ && !($$0 ~ "/" pc "/") {id = match($$0, /\/[^\/]+\.py[co]$$/); if (id != 0) {d = substr($$0, 1, RSTART - 1); dirs[d] = 1}; sub(/\.py[co]$$/, "." mt "&"); sub(/[^\/]+\.py[co]$$/, pc "/&"); print; next} \
+ /^@dirrm / {d = substr($$0, 8); if (d in dirs) {print $$0 "/" pc}; print $$0; next} \
+ {print} \
+ END {if (sp in dirs) {print "@dirrm " sp "/" pc}} \
+ ' \
+ pc="__pycache__" mt="$$(${PYMAGICTAG})" sp="${PYTHON_SITELIBDIR:S,${PYTHONBASE}/,,g}" \
+ ${TMPPLIST} > ${TMPPLIST}.pyc_tmp
+ @${MV} ${TMPPLIST}.pyc_tmp ${TMPPLIST}
+.endif
+
+.include <bsd.port.post.mk>