aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-qt4-sql/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/py-qt4-sql/Makefile')
-rw-r--r--databases/py-qt4-sql/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/databases/py-qt4-sql/Makefile b/databases/py-qt4-sql/Makefile
index fe3fe76c1240..a5f0d0ee9b64 100644
--- a/databases/py-qt4-sql/Makefile
+++ b/databases/py-qt4-sql/Makefile
@@ -8,11 +8,11 @@ CATEGORIES= databases devel python
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt4 toolkit, QtSql module
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:${PORTSDIR}/devel/py-sip
-RUN_DEPENDS= ${PKGNAMEPREFIX}gui>=${PYQT4_VERSION}:${PORTSDIR}/x11-toolkits/py-qt4-gui
-
CONFIGURE_ARGS= --enable QtSql
-PYQT4_DIST= yes
+PYQT_DIST= yes
+
+USES= python pyqt:4
+USE_PYQT= sip_build gui_run
USE_QT4= moc_build gui sql qmake_build
OPTIONS_DEFINE= API DEBUG
@@ -25,5 +25,4 @@ API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
DEBUG_CONFIGURE_ON= --debug --trace
-.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
.include <bsd.port.mk>