aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-sqlobject/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/py-sqlobject/Makefile')
-rw-r--r--databases/py-sqlobject/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/databases/py-sqlobject/Makefile b/databases/py-sqlobject/Makefile
index b3e536b31277..7e4dc6b27252 100644
--- a/databases/py-sqlobject/Makefile
+++ b/databases/py-sqlobject/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sqlobject
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= databases python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,4 +24,13 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-M
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
.include <bsd.port.mk>