aboutsummaryrefslogtreecommitdiffstats
path: root/databases/qt-odbc-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'databases/qt-odbc-plugin')
-rw-r--r--databases/qt-odbc-plugin/Makefile3
-rw-r--r--databases/qt-odbc-plugin/files/patch-src-sql-drivers-odbc-qsql_odbc.cpp21
2 files changed, 23 insertions, 1 deletions
diff --git a/databases/qt-odbc-plugin/Makefile b/databases/qt-odbc-plugin/Makefile
index 1e1e53296ea4..d38c05c6b2f0 100644
--- a/databases/qt-odbc-plugin/Makefile
+++ b/databases/qt-odbc-plugin/Makefile
@@ -8,7 +8,7 @@
PORTNAME= qt-${DB}-plugin
PORTVERSION= 3.3.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_QT}
DISTNAME= qt-x11-free-${PORTVERSION}
@@ -25,6 +25,7 @@ BROKEN= does not compile
LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC \
qt-mt:${PORTSDIR}/x11-toolkits/qt33
+BUILD_DEPENDS= unixODBC>=2.2.14_1:${PORTSDIR}/databases/unixODBC
USE_BZIP2= yes
PLUGIN= plugins/src/sqldrivers/${DB}
diff --git a/databases/qt-odbc-plugin/files/patch-src-sql-drivers-odbc-qsql_odbc.cpp b/databases/qt-odbc-plugin/files/patch-src-sql-drivers-odbc-qsql_odbc.cpp
new file mode 100644
index 000000000000..bb07b52f8acc
--- /dev/null
+++ b/databases/qt-odbc-plugin/files/patch-src-sql-drivers-odbc-qsql_odbc.cpp
@@ -0,0 +1,21 @@
+--- src/sql/drivers/odbc/qsql_odbc.cpp.orig 2009-01-26 23:43:41.000000000 +0600
++++ src/sql/drivers/odbc/qsql_odbc.cpp 2009-01-26 23:43:53.000000000 +0600
+@@ -57,18 +57,8 @@
+ #endif
+
+ // newer platform SDKs use SQLLEN instead of SQLINTEGER
+-#ifdef SQLLEN
+ # define QSQLLEN SQLLEN
+-#else
+-# define QSQLLEN SQLINTEGER
+-#endif
+-
+-#ifdef SQLULEN
+ # define QSQLULEN SQLULEN
+-#else
+-# define QSQLULEN SQLUINTEGER
+-#endif
+-
+
+ static const QSQLLEN COLNAMESIZE = 256;
+ //Map Qt parameter types to ODBC types