aboutsummaryrefslogtreecommitdiffstats
path: root/databases/redigo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/redigo/Makefile')
-rw-r--r--databases/redigo/Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/databases/redigo/Makefile b/databases/redigo/Makefile
index 36e8afce60e0..cc3ac91a3052 100644
--- a/databases/redigo/Makefile
+++ b/databases/redigo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= redigo
PORTVERSION= 20130702
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= LOCAL/gblach/
@@ -10,17 +11,7 @@ MAINTAINER= gblach@FreeBSD.org
COMMENT= Go client for the Redis database
WRKSRC= ${WRKDIR}/${DISTNAME}/redis
-SUBLIBDIR= github.com/garyburd/${PORTNAME}
-GO_PKGNAME= ${SUBLIBDIR}/redis
-
-NO_STAGE= yes
-do-install:
- ${MKDIR} ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
- ${INSTALL_DATA} ${GO_WRKDIR_PKG}/${SUBLIBDIR}/redis.a ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
- ${MKDIR} ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}
-.for f in conn.go doc.go log.go pool.go pubsub.go redis.go reply.go scan.go script.go
- ${INSTALL_DATA} ${GO_WRKSRC}/${f} ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}
-.endfor
+GO_PKGNAME= github.com/garyburd/${PORTNAME}/redis
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/go/files/bsd.go.mk"