aboutsummaryrefslogtreecommitdiffstats
path: root/databases/sqldeveloper/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/sqldeveloper/Makefile')
-rw-r--r--databases/sqldeveloper/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/databases/sqldeveloper/Makefile b/databases/sqldeveloper/Makefile
index 2bcba58880b0..c7ac766e7c03 100644
--- a/databases/sqldeveloper/Makefile
+++ b/databases/sqldeveloper/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sqldeveloper
-PORTVERSION= 4.0.3.16.84
+PORTVERSION= 4.1.0.19.07
DISTVERSIONSUFFIX=-no-jre
CATEGORIES= databases java
MASTER_SITES= #http://www.oracle.com/technetwork/developer-tools/sql-developer/overview/index.html
@@ -16,7 +16,7 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USES= zip
USE_JAVA= yes
-JAVA_VERSION= 1.7+
+JAVA_VERSION= 1.8+
NO_BUILD= yes
@@ -32,7 +32,7 @@ SUB_LIST= JAVA_HOME=${JAVA_HOME} PORTNAME=${PORTNAME}
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= due to Oracle license restrictions, you must fetch the source \
distribution manually. Please access \
-http://www.oracle.com/technology/software/products/sql/index.html \
+http://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/index.html \
with a web browser and follow the link for the ${DISTFILES}. You will be \
required to register and log in, but you can create an account on that \
page. After registration and accepting the Oracle License, download the \
@@ -47,7 +47,7 @@ do-install:
.for d in configuration dataminer dropins dvt equinox \
external ide javavm jdbc jdev jlib jviews modules \
- lib netbeans rdbms sleepycat sqldeveloper sqlj svnkit
+ netbeans ords rdbms sleepycat sqlcl sqldeveloper sqlj svnkit
${ECHO_MSG} -n ">> Installing data directory '${d}'..."
cd ${WRKSRC} && ${FIND} ${d} -type d \
-exec ${MKDIR} ${STAGEDIR}/${DATADIR}/\{} \;
@@ -57,6 +57,8 @@ do-install:
-not -name "*.bat" \
-not -name "*.bak" \
-not -name "*.dll" \
+ -not -name "*.so" \
+ -not -name "*.jnilib" \
-exec ${INSTALL_DATA} \{} ${STAGEDIR}/${DATADIR}/\{} \;
${ECHO_MSG} " [ DONE ]"
.endfor