aboutsummaryrefslogtreecommitdiffstats
path: root/databases/sqlite2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/sqlite2/Makefile')
-rw-r--r--databases/sqlite2/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index 45525057e510..816948a3ba32 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.sqlite.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= SQL database engine in a C library
-USES= gmake pkgconfig
+USES= gmake pkgconfig readline
USE_AUTOTOOLS= libtool
USE_LDCONFIG= YES
@@ -19,12 +19,14 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
DOCSDIR= ${PREFIX}/share/doc/sqlite2
EXAMPLESDIR= ${PREFIX}/share/examples/sqlite2
-LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}2
-
EXTRACT_AFTER_ARGS= --exclude CVS
OPTIONS_DEFINE= TCL THREADS DOCS
+.if !exists(/usr/lib/libreadline.so)
+MAKE_ARGS= READLINE_FLAGS="-DHAVE_READLINE=1 -I${LOCALBASE}/include -L${LOCALBASE}/lib"
+.endif
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTCL}